directed D2400 - Page 2 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th August 2011, 01:51 AM   #11
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Does this amp use both N-channel and P-channel FETs for outputs?
  Reply With Quote
Old 29th August 2011, 01:55 AM   #12
diyAudio Member
 
Join Date: Sep 2006
Yes...


I think i might have found the problem..


There was a hair-line crack in the solder connection to the output filter inductior..


I reflowed the solder and the amp powers up and plays audio right now...


I also noticed 1 of the transformmers has loose windings since it crackels
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Directed D2400 mike49504 Car Audio 5 26th July 2011 03:25 AM
Directed 650 mike49504 Car Audio 6 15th September 2010 06:04 PM
directed d2400 mike49504 Car Audio 17 24th August 2010 12:23 AM
Directed 1100 D mike49504 Car Audio 4 2nd August 2010 05:03 AM
Directed D2400 mike49504 Car Audio 10 20th April 2010 04:52 AM


New To Site? Need Help?

All times are GMT. The time now is 02:36 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2