stetsom 14k5 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th August 2011, 10:58 PM   #1
diyAudio Member
 
Join Date: Oct 2009
Default stetsom 14k5

Hi
I`m working on a stetsom 14k5.
so far I have replaced 5 output
mosfet, and the 5 gate resistors.
the amp powers up and has audio,
but there`s -20 volts at the output.
any sugestion?
Thanks in advance.
__________________
fluke 50 mhz scope,35 amp power supply,0.5-12v adj power supply, fluke 179,hot air desolder gun, merit multyfuntion signal tracer/generator.
  Reply With Quote
Old 11th August 2011, 11:56 PM   #2
diyAudio Member
 
Join Date: Oct 2009
HI:
againg having problems with this
unit, after replacing one of the
driver board with an other use
one, know I have -02 volts for
about 3 seconds, then it goes
to -2.7 volts, at the speakers
output. any suggestions?
__________________
fluke 50 mhz scope,35 amp power supply,0.5-12v adj power supply, fluke 179,hot air desolder gun, merit multyfuntion signal tracer/generator.
  Reply With Quote
Old 12th August 2011, 12:40 AM   #3
fcruz is offline fcruz  Brazil
diyAudio Member
 
Join Date: Apr 2011
you've changed the 4011 check i, c u2 adjust the trimpot to off set
  Reply With Quote
Old 12th August 2011, 12:47 AM   #4
diyAudio Member
 
Join Date: Oct 2009
Yes: I replaced the driver board, and ic 4011.
So I need to adjust the tripot?
__________________
fluke 50 mhz scope,35 amp power supply,0.5-12v adj power supply, fluke 179,hot air desolder gun, merit multyfuntion signal tracer/generator.
  Reply With Quote
Old 12th August 2011, 01:19 AM   #5
fcruz is offline fcruz  Brazil
diyAudio Member
 
Join Date: Apr 2011
yes
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
stetsom 1k5 h megael9 Car Audio 8 26th July 2011 01:03 AM
stetsom megael9 Car Audio 27 4th July 2011 11:40 PM


New To Site? Need Help?

All times are GMT. The time now is 01:20 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2