Kenwood KEC-600 crossover - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th August 2011, 06:31 AM   #1
diyAudio Member
 
Join Date: Sep 2006
Default Kenwood KEC-600 crossover

I got this in for repair .. The guy told me that it blows up every amp he connects to it..


If i test from B+ to rca shield my readings are in the mega ohms ...


Any ideas??
  Reply With Quote
Old 4th August 2011, 09:36 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Do you have continuity between the shields of all of the OUTPUT RCAs?

If you do, connect it to a working amp (under controlled conditions so that it can't damage the amp) and see if it causes any problems.
  Reply With Quote
Old 20th August 2011, 07:28 PM   #3
diyAudio Member
 
Join Date: Aug 2011
I have a Kenwood KEC-1000 Crossover the last amplifier that was connected to this crossover was dammaged and now the protection light stay's on and will not go off. I have continuity between two of the three shields comming out of the crossover but the Low range output shield is missing there's no continuity between the low range output and the rest of the output's, Is this the reason for it dammaging this amplifier. I saw in another post from Perry Babin that say's this can be the reason for the crossover dammaging amplifier dose anyone have any idea's
audioquest1957@gmail.com
  Reply With Quote
Old 20th August 2011, 09:26 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If you need help with this, start a new thread. Include the make/model of the xo and the symptoms in the subject line. Before posting, remove the cover and look for burned traces between the shield grounds.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FS/Trade Hammond 850G 150/600:150/600 Line Isolation/Hybrid Matching Transformers VictoriaGuy Swap Meet 0 3rd August 2011 09:29 PM
Kenwood KAC-1023 crossover/gain board, same as in other *23-series? gisewhcs Car Audio 9 25th January 2011 02:04 AM
Where to get Sanyo or KEC parts? Everlast Parts 9 11th July 2009 05:35 PM
Wanted- Kenwood Kec-202 manual junglejuice Car Audio 2 7th April 2008 08:43 AM
WTB: 600/600 line out trannys mobyd Swap Meet 0 13th February 2006 06:30 PM


New To Site? Need Help?

All times are GMT. The time now is 11:07 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2