XTant X604 pray picture - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 3rd August 2011, 06:44 PM   #1
diyAudio Member
 
Join Date: May 2011
Default XTant X604 pray picture

Hey! I have a xtant604x, it is not working properly, Don't know what is the model,the Resistance use not correct. who has the amp? can you help me upload the picture, i really have no other way to fix it. thank you for your help.
Attached Images
File Type: jpg 201108041107.jpg (966.6 KB, 67 views)

Last edited by ALPINE AJ; 3rd August 2011 at 07:05 PM.
  Reply With Quote
Old 3rd August 2011, 07:02 PM   #2
diyAudio Member
 
Join Date: May 2011
Quote:
Originally Posted by ALPINE AJ View Post
Hey! I have a xtant604x, it is not working properly, Don't know what is the model,the Resistance use not correct. who has the amp? can you help me upload the picture, i really have no other way to fix it. thank you for your help.
  Reply With Quote
Old 3rd August 2011, 07:05 PM   #3
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Which resistor?
  Reply With Quote
Old 3rd August 2011, 07:07 PM   #4
diyAudio Member
 
Join Date: May 2011
Do you have a picture?
  Reply With Quote
Old 3rd August 2011, 07:10 PM   #5
diyAudio Member
 
Join Date: May 2011
Quote:
Originally Posted by Perry Babin View Post
Which resistor?
Pictures of all resistance
  Reply With Quote
Old 3rd August 2011, 07:18 PM   #6
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
http://www.bcae1.com/temp/IMG_0930.JPG

This is the best I have showing most of the ones in that area. It's not exactly the same model number but it appears to be close.
  Reply With Quote
Old 3rd August 2011, 07:26 PM   #7
diyAudio Member
 
Join Date: May 2011
Quote:
Originally Posted by Perry Babin View Post
http://www.bcae1.com/temp/IMG_0930.JPG

This is the best I have showing most of the ones in that area. It's not exactly the same model number but it appears to be close.
Ok. thanks
  Reply With Quote
Old 3rd August 2011, 07:31 PM   #8
adason is offline adason  United States
diyAudio Member
 
adason's Avatar
 
Join Date: Nov 2004
Location: Maryland
it seems like the diode D107 (lower left corner) seems completely crooked
  Reply With Quote
Old 3rd August 2011, 07:32 PM   #9
adason is offline adason  United States
diyAudio Member
 
adason's Avatar
 
Join Date: Nov 2004
Location: Maryland
I suppose its a diode, since transistors are usually labeled as Q...
although it has three legs
  Reply With Quote
Old 5th August 2011, 12:46 AM   #10
diyAudio Member
 
Join Date: Aug 2011
Click the image to open in full size.
I just got this 603x. I talked to xtant and they still repair them so that may be an option for you.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
XTant X604 HELP HELP!!!! ALPINE AJ Car Audio 3 26th April 2013 07:15 AM
Xtant X604 Repair 91h22a Car Audio 27 18th March 2011 05:09 AM
xtant x604 mike49504 Car Audio 3 13th January 2009 06:23 PM
xtant x604 dc offset shagone Car Audio 8 24th March 2008 07:34 PM


New To Site? Need Help?

All times are GMT. The time now is 11:08 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2