diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Car Audio (http://www.diyaudio.com/forums/car-audio/)
-   -   SSS 2000 resistors getting hot (http://www.diyaudio.com/forums/car-audio/193297-sss-2000-resistors-getting-hot.html)

Mote 26th July 2011 06:24 PM

SSS 2000 resistors getting hot
 
1 Attachment(s)
Just a quick question about Sophisticated Sonic Systems 2000 amp.
Amp had shorted zener (15V 1W) and therefore there was no audio. The 220 ohm 3W resistors, which are connect zeners to rail voltage, were so hot that I actually burned my finger.
Replaced the zener and now amp runs fine, no current draw, plays music and voltages on various points seem right.

But the 220 ohm 3W resistors still get quite hot, I can hold my finger on them for a few seconds but not longer, is that normal?

Rail voltage is 34V and zeners are 15V. I measured 19V across the resistors. They measure both 220 ohms.

If they are supposed to run that hot I would probably like to replace them for 220 ohm 5W resistors. Those should not get that hot?

Resistors in question are between transformer/rail caps and audio sections on the photo. Sorry about poor picture quality.

1moreamp 26th July 2011 06:56 PM

3 watt or 5 watt they are all going to exhibit some heat issues as its the voltage drop across the resistor that is causing the high heat issues. Since the resistor did not fail its likely that there is no gain for increasing its total wattage except possibly some more surface area to emit the heat from IMHO. :)


PS there is a expensive fix for this, and that you could use Vishay TO-220 metal film resistors and mount them under the PC Board against the sink so the heat sink would act to emit the heat to the outside air. This is expensive, and has pretty much zero performance gain to the amp except to give this heat source a outside exit from the amp. The Vishay's are isolated tab design so some simple silicon grease and no insulators are required. Again this is very expensive as these resistors are Mil spec and when found will not be economical to purchase.

Mote 26th July 2011 07:15 PM

Thanks. I figured that the high voltage drop is the "fault". I will leave like it is then.

1moreamp 26th July 2011 07:24 PM

I have run into this same issue on many amps so its nothing new. Some amps are just designed better then others. I see one of the resistors has turned color, this most likely happened when the zener shorted. As long as its within tolerance you should be OK as-is.
Better made amps used Three terminal regulators that are sink mounted so the Voltage drop is handled by the sink. Or they use separate windings on the power toroid to get lower voltage drop issues to the lower rails. Each of these methods has its limitations and issues, mostly cost and complexity related... :)


All times are GMT. The time now is 04:46 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2