Kicker 1500.1 - Page 2 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 15th September 2011, 09:04 PM   #11
diyAudio Member
 
Join Date: Sep 2006
Got everything put back in this amp.. Powers up and idles fine ..

It produces audio but distorted.. Any ideas??
  Reply With Quote
Old 15th September 2011, 09:08 PM   #12
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Do you have clean audio on the 'IN' pin of the class D driver board?

Do you have a clean rail to rail square wave on the outputs?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kicker ZX 1500.1 Smoked general_neo Car Audio 11 8th March 2013 04:17 AM
Kicker 1500.1 problem Andrew123654 Car Audio 1 2nd November 2010 11:59 PM
Kicker ZX 1500.1 Spkr relay dropping early Scanlines Car Audio 3 21st October 2010 10:18 AM
kicker 1500.1 mike49504 Car Audio 66 14th July 2010 06:09 PM


New To Site? Need Help?

All times are GMT. The time now is 01:00 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2