Rockford Fosgate Punch 500x 4 channel - Page 3 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th April 2011, 04:29 PM   #21
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
I checked them all even the fronts and did not find any leaking. I applied power and none of the channels will bias and they are all staticy and distorted. I must have several bad smd components. I dont know where to begin. The voltage is back from gate to source. All this came after I tried hooking up speakers. So obviously I still have the same problem. No components seem to be smoking on the board now, maybe because they have failed.

I still dont have any DC on the bridging terminals on front or rear so thats a good thing I guess.
  Reply With Quote
Old 27th April 2011, 05:36 PM   #22
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
What is the voltage across Rx19?
  Reply With Quote
Old 27th April 2011, 05:43 PM   #23
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
R "x" 19? What is the "x"?
  Reply With Quote
Old 27th April 2011, 05:52 PM   #24
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
I tested R19 if thats what you needed and it has 0.000 vdc across it. Its wierd when I touch just one of the probes to it the amp starts making a squelching noise somewhere by the transformer and some other stuff starts clicking on the board.
  Reply With Quote
Old 27th April 2011, 08:05 PM   #25
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
It's a 4 channel amp. Rx19 means R119, R219, R319 or R419. They should all have the same voltage.
  Reply With Quote
Old 28th April 2011, 02:18 AM   #26
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
R119: 1.701 vdc

R219: 1.699 vdc

R319: 1.703 vdc

R419: 1.603 vdc
  Reply With Quote
Old 28th April 2011, 02:30 AM   #27
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Do you see a clean signal on C412 and C314?
  Reply With Quote
Old 28th April 2011, 02:53 AM   #28
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Quote:
Originally Posted by Perry Babin View Post
Do you see a clean signal on C412 and C314?
Soon as I started driving a signal something popped in the amp. The LR+ bridging terminal now has -30.67 vdc on it. The drain for Q410 (IRF540) has -30.65 vdc and the drain for Q411 (IRF9540) has -30.65 vdc.

I see a clean signal both sides of C314, nice waveform and clipping at high volume.

C412 has a clean signal on one side just like C314 but its different on the other side. When I touch the scope probe to the other side of C412 the baseline drops 3 divisions and the waveform is funny looking. Its like double stacked over top of its self if you will. That side of C412 also has -15.02 vdc on it as well and it does not amplify like the other signals. It only goes 1 divisions before showing clip where the others go 3 to 4 divisions before showing clip.

Last edited by seankane; 28th April 2011 at 02:56 AM.
  Reply With Quote
Old 28th April 2011, 02:59 AM   #29
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The DC on the cap is due to the DC on the output.
  Reply With Quote
Old 28th April 2011, 09:31 PM   #30
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Should I start tracing back from the cap to see if I can find anything out of tolerance, or do you think I should check else where?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rockford Fosgate Punch 400a4 seankane Car Audio 62 14th April 2011 06:38 AM
Rockford Fosgate Punch 75.2 static channel chipper Car Audio 7 30th January 2011 09:52 AM
Rockford Fosgate Punch P325.2 mbates14 Car Audio 2 25th November 2010 03:11 AM
Repairing Rockford fosgate punch 40X2 channel help chipper Car Audio 17 26th August 2010 10:29 PM
rockford fosgate punch z stevena2006 Car Audio 2 23rd December 2009 04:20 PM


New To Site? Need Help?

All times are GMT. The time now is 09:23 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2