Crossfire amp help please cfa-602 - Page 2 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 18th April 2011, 02:09 PM   #11
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Those appear to be OK.

Having -10v on the secondary ground is strange. You could try connecting one of the non-bridging speaker terminals to the amp ground to see what gets hot. Have all transistors clamped to the sink if/when you do this.
  Reply With Quote
Old 18th April 2011, 02:14 PM   #12
diyAudio Member
 
Join Date: Jan 2011
Should I keep my little three amp power supply connected because as I said it shuts down at 3 amps, I have a ten and a fifty amp as well
  Reply With Quote
Old 18th April 2011, 02:16 PM   #13
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Try it with the 3 amp supply first. You may need to go to the 10 amp. You won't need the 50 amp for this.
  Reply With Quote
Old 18th April 2011, 02:25 PM   #14
diyAudio Member
 
Join Date: Jan 2011
ok it does nothing different with the three amp however just a question d105 and d205 in the audio section of the amp have no voltage drop
  Reply With Quote
Old 18th April 2011, 02:28 PM   #15
diyAudio Member
 
Join Date: Jan 2011
but they are O/L when the meter leads are but backwards
  Reply With Quote
Old 18th April 2011, 02:35 PM   #16
diyAudio Member
 
Join Date: Jan 2011
one more thing that is strange, when i used my scope I was showing both + and - at the same time when the amp tried to power up, on the black end of all the zenners, the white end was fine.
  Reply With Quote
Old 18th April 2011, 02:40 PM   #17
diyAudio Member
 
Join Date: Jan 2011
Almost sounds like a z44 is stuck open but as i said I have had them all out of the amp and checked them, they are all also showing both + and - when the amp tries to power up but only for a split second, just when the amp is at full power, anything under 12 volts is stable
  Reply With Quote
Old 18th April 2011, 02:48 PM   #18
diyAudio Member
 
Join Date: Jan 2011
I have had all the caps out tested them with my cap tester at full voltage including the 6800 uf there was none leaking or shorting, of course i have not taken any of the small caps out, just checked those for shorting with my meter
  Reply With Quote
Old 18th April 2011, 10:20 PM   #19
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
D105 and D205 are likely for the protection circuit and would not have voltage across them unless the amp was going into protect mode.

What do you mean 'showing + and -'? Can you post a photo of the scope display?
  Reply With Quote
Old 19th April 2011, 02:07 AM   #20
diyAudio Member
 
Join Date: Jan 2011
I mean the trace splits the same time up and down twelve volts, thats why the amp is shutting down because the protection kicks in as soon as it powers up
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
crossfire cfa-602, car audio amp problem tuneman Car Audio 29 23rd September 2010 05:08 AM
crossfire cfa-602, car audio amp problem tuneman Solid State 1 11th September 2010 01:51 PM
crossfire amp mike49504 Car Audio 4 12th January 2010 07:49 AM
Crossfire vr1000D sub amp no1stunna Swap Meet 0 21st February 2009 08:59 PM
Mirand A1 CFA-Amp (Pictures) welcome comments ! pixworld Solid State 23 11th January 2005 11:22 AM


New To Site? Need Help?

All times are GMT. The time now is 01:42 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2