JL Audio 300/4 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th April 2011, 08:17 PM   #1
Dr Zeus is offline Dr Zeus  United States
diyAudio Member
 
Dr Zeus's Avatar
 
Join Date: Oct 2010
Default JL Audio 300/4

Im not 100% sure what is wrong with this amp. i know these amps are quite finiky with my test equipment and often present signs of feedback/humming.

At first this amp seemed OK, but then my test speaker crackled and almost blew out while connected to the channels in the center of the amplifier. I re-soldered all 8x 47k resistors on the driver boards as I saw that mentioned in another thread. After which, the speaker crackled once more, and now I cannot get it to do it again. Im thinking a bad switch or intermittent crossover module connection.

Any ideas? The amp seems just fine now. Seems this happens to me a lot with this series JL Audio amplifiers.
  Reply With Quote
Old 11th April 2011, 10:43 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The connections on the sockets are sometimes weak. Unplugging the board and plugging it back in a few times generally clears it up.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
JL Audio 10w6v2 or Infinity Kappa 100.3se? Audison SRX4 or Jl 300/4? DcMaN Subwoofers 1 17th September 2010 10:28 AM
jl audio 300/4 repair brianfulcher15 Car Audio 3 16th June 2009 05:45 AM
Help to repair JL audio 300/2 Solosound Car Audio 42 20th March 2009 12:52 AM
JL Audio 300/4 PQatPIT Car Audio 5 4th March 2009 02:06 PM
jl audio 300 2 ppia600 Car Audio 2 6th April 2008 03:54 PM


New To Site? Need Help?

All times are GMT. The time now is 10:45 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2