Rockford Fosgate Power 450S - Page 6 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Thread Tools Search this Thread
Old 14th April 2011, 07:04 PM   #51
diyAudio Member
seankane's Avatar
Join Date: May 2010
Location: Washington State
Maybe it was broken from one of the solder pads and just not visible to the naked eye. Resoldering a new one on made the contact and eliminated the problem?
  Reply With Quote
Old 14th April 2011, 09:05 PM   #52
diyAudio Member
Join Date: Nov 2003
Location: Louisiana
Not if you measured 16v directly across the pads for the resistor.
  Reply With Quote
Old 16th April 2011, 12:21 AM   #53
diyAudio Member
seankane's Avatar
Join Date: May 2010
Location: Washington State
Replaced cross over selector switch, RCA jacks, 2 IN4003 and the amp works beautifully. Thanks for all of the help.
  Reply With Quote


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rockford Fosgate Power 20001 bd amplifier power rating?? pachoorion Car Audio 8 8th May 2011 11:49 PM
Rockford Fosgate Power 360a2 seankane Car Audio 219 26th April 2011 08:37 AM
Rockford Fosgate Power 1000a2 seankane Car Audio 31 6th April 2011 05:23 AM
Help with Rockford Fosgate Power 650 shawnk Car Audio 31 14th July 2010 09:11 PM

New To Site? Need Help?

All times are GMT. The time now is 07:17 AM.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2