MRP-T130 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th April 2011, 07:05 AM   #1
diyAudio Member
 
Join Date: Apr 2011
Default MRP-T130

My cousin tried fixing and amp like this. He said he changed a couple of mosfets but it didn't solve the problem. Then he gave me the amp so I decided to take a stab at it. I was hoping someone had the schematic, parts list or picture of the circuit board so that I can confirm he installed the correct mosfets. Any help would be greatly appreciated.
  Reply With Quote
Old 10th April 2011, 09:45 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
What does the amp do when you power it up?
  Reply With Quote
Old 10th April 2011, 07:07 PM   #3
diyAudio Member
 
Join Date: Apr 2011
I wasn't there when he powered it up and its been a couple of years since he attempted this repair so he doesn't remember. I only know that he change two of the fets. I wanted to confirm they were correct before I powered it up and possibly did more damage. The two fets I'm talking about are N2D F10P20F & N2D F10P20FR.
  Reply With Quote
Old 10th April 2011, 07:14 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Those aren't FETs, they're rectifiers.

If you insert a 10 amp fuse in the B+ line and have all semiconductors tightly clamped to the heatsink, you shouldn't do any more damage (assuming that the rectifiers are installed in the correct locations - the board should be marked).
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
alpine mrp-m1000 mike49504 Car Audio 47 17th June 2013 11:48 AM
alpine mrp-f250 bdgf2004 Car Audio 12 2nd September 2011 04:26 AM
Alpine MRP-M450 Dr Zeus Car Audio 9 1st January 2011 04:52 PM
Alpine MRP-M350 RiLoWa Car Audio 37 3rd December 2010 08:23 PM


New To Site? Need Help?

All times are GMT. The time now is 08:34 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2