diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Car Audio (http://www.diyaudio.com/forums/car-audio/)
-   -   MRP-T130 (http://www.diyaudio.com/forums/car-audio/186764-mrp-t130.html)

canadianeh 10th April 2011 07:05 AM

MRP-T130
 
My cousin tried fixing and amp like this. He said he changed a couple of mosfets but it didn't solve the problem. Then he gave me the amp so I decided to take a stab at it. I was hoping someone had the schematic, parts list or picture of the circuit board so that I can confirm he installed the correct mosfets. Any help would be greatly appreciated.

Perry Babin 10th April 2011 09:45 AM

What does the amp do when you power it up?

canadianeh 10th April 2011 07:07 PM

I wasn't there when he powered it up and its been a couple of years since he attempted this repair so he doesn't remember. I only know that he change two of the fets. I wanted to confirm they were correct before I powered it up and possibly did more damage. The two fets I'm talking about are N2D F10P20F & N2D F10P20FR.

Perry Babin 10th April 2011 07:14 PM

Those aren't FETs, they're rectifiers.

If you insert a 10 amp fuse in the B+ line and have all semiconductors tightly clamped to the heatsink, you shouldn't do any more damage (assuming that the rectifiers are installed in the correct locations - the board should be marked).


All times are GMT. The time now is 05:21 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2