Memphis 16-ST1000D - Page 3 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th April 2011, 03:01 PM   #21
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
With the driver boards in, you should have a 10v (viewed on the scope) signal on the gates. This would read about 5v on your meter. Subtract that from 63 and you get approximately what you're seeing.

Look at the drive signals for Q212 and Q214. How do they differ?
  Reply With Quote
Old 5th April 2011, 05:13 PM   #22
Dr Zeus is offline Dr Zeus  United States
diyAudio Member
 
Dr Zeus's Avatar
 
Join Date: Oct 2010
V/Div set to 2v and 2uS

Q212 and Q214 look similar:
Click the image to open in full size.

Q256 and Q216:
Click the image to open in full size.


and finally Q253. If I press on the driver board the signal on Q253 turns into the same signal seen on Q212/Q214:
Click the image to open in full size.

So there is definately something wrong or loose on at least one of the driver boards. Also some of the corners of the gate signal seem to be slightly rounded.
  Reply With Quote
Old 5th April 2011, 05:36 PM   #23
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
There may be a bad connection in the header. You may need to remove the plastic housing and tighten the contacts (Tech Tips 7, item #6).
  Reply With Quote
Old 16th April 2011, 04:23 AM   #24
Dr Zeus is offline Dr Zeus  United States
diyAudio Member
 
Dr Zeus's Avatar
 
Join Date: Oct 2010
I fixed the driver board on this amp. Turned out one of the 1 ohm resistors had a crack in it. All IRF650/9650 outputs are stable and the amp is able to produce clean audio. I just got my fresh order of IRF3205 fets for the PS and just need to know if the 22ohm gate resistors are a good match?
  Reply With Quote
Old 16th April 2011, 04:53 AM   #25
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
That's what was originally in it.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Memphis 16-ST500D mike49504 Car Audio 21 4th August 2014 12:30 AM
Memphis 16-st1000d Componentr Car Audio 13 8th October 2012 03:01 AM
Memphis 16-MC1000D mike49504 Car Audio 17 23rd February 2011 07:51 AM
Memphis 16-ST1000D Question spooney Car Audio 4 29th December 2010 07:19 PM
Memphis 16-st1000d mike49504 Car Audio 46 19th May 2010 08:40 AM


New To Site? Need Help?

All times are GMT. The time now is 05:22 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2