Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Orion Cobalt 304, 1 channel not working
Orion Cobalt 304, 1 channel not working
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th March 2011, 10:44 PM   #11
ash4kel is offline ash4kel  United States
diyAudio Member
 
Join Date: Mar 2011
Sorry to waste your time, I found the problem and it was a bad RCA.
  Reply With Quote

Reply


Orion Cobalt 304, 1 channel not workingHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
NAD 304 integrated amp one channel fading problem dima2ooo Solid State 59 17th November 2014 03:01 PM
About to pull my hair out! Working on ORION 2250 Samuel Rock Car Audio 9 24th December 2008 02:13 PM
12 Channel Amp - perefect for active projects like the Orion mbcouple Swap Meet 1 5th November 2008 01:24 PM
8 Channel Amplifier for Linkwitz Orion Kit ngiachin Chip Amps 12 9th July 2004 08:13 PM
Zen4..only one channel working.. frankv Pass Labs 10 2nd December 2002 02:08 PM


New To Site? Need Help?

All times are GMT. The time now is 11:22 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki