MPSA56 / MPSA06 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 25th March 2011, 11:34 PM   #1
Rabbi is offline Rabbi  United States
diyAudio Member
 
Join Date: Jan 2011
Default MPSA56 / MPSA06

I Am replacing parts on my PPI PCX1500 and i need to replace the MPS A56 and MPS A06.

Mouser has both parts in stock. But lists different frequency's and different emitter voltages.

I Was wondering what ones i should be using for this amp?

50mhz or 100mhz, and 4v or 5V ?

Thanks
  Reply With Quote
Old 26th March 2011, 01:15 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Any MPSA06 or MPSA56 should work.
  Reply With Quote
Old 26th March 2011, 01:27 AM   #3
Rabbi is offline Rabbi  United States
diyAudio Member
 
Join Date: Jan 2011
thanks Perry
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MPSA56 replacement timwebb Car Audio 3 10th February 2011 08:29 PM
Looking for substitute Transistors for MPSA56, MPSA06 robin2d Parts 5 18th October 2004 07:44 PM
Using MPSA56/06 in A40 10kv Pass Labs 2 6th February 2002 02:12 PM


New To Site? Need Help?

All times are GMT. The time now is 02:10 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2