Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th March 2011, 12:07 AM   #1
diyAudio Member
 
Deadly Sones's Avatar
 
Join Date: Feb 2011
Location: Windsor, Ontario
Default Punch 60X2 RT SP distortion

Hello,

A friend gave me his OS punch 60x2 (trans-ana design)to look at... it appears that the right channel is severely distorted.

I tested the speaker - to the RCA shield ground of both... the left hand is 1K ohms and the right (bad) side is 20K ohms... not sure if that means anything, but I've looked over both sides of the amp and there are no lifted traces and no visible signs of damage.

It powers up fine, left channel sounds o.k. but right side has huge distortion... any ideas how I can go about troubleshooting this amp?

Thanks in advance,
Paul

p.s. I've read over Dr. Zues' thread about his punch problem... this seems to be different.

Last edited by Deadly Sones; 14th March 2011 at 12:11 AM.
  Reply With Quote
Old 14th March 2011, 12:28 AM   #2
diyAudio Member
 
Deadly Sones's Avatar
 
Join Date: Feb 2011
Location: Windsor, Ontario
Should there be a .1 ohm resistor in location R236? I have one in R136, 163 and 263, but the one in R236 appears to be missing... not sure if that could be a problem... just something I noticed on the board...
  Reply With Quote
Old 14th March 2011, 04:47 AM   #3
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
There should be one 0.1 ohm resistor for each output transistor.

If the resistor is missing and the legs aren't still in the solder pads, it likely got hot enough to desolder itself. If that's the case, make sure that you clamp all transistors tightly to the heatsink before applying power (after replacing the resistor).
  Reply With Quote
Old 16th March 2011, 01:31 AM   #4
diyAudio Member
 
Deadly Sones's Avatar
 
Join Date: Feb 2011
Location: Windsor, Ontario
Thanks Perry. I just got the resistor today, and sure enough it works perfectly with it installed... was really strange... almost like the resistor was never there... I guess it could have heated up and fell out many years ago. Works great now!!!

On to the next project...
  Reply With Quote
Old 21st March 2011, 03:55 AM   #5
diyAudio Member
 
Join Date: Mar 2011
Hi.I got broken amp punch 60x2.Same like you got.If you kan tel me some information.I kant read numbers of the CR1 ,CR2,Q6,Q7.Please help me.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rockford Punch 60x2 DSM Dr Zeus Car Audio 31 22nd January 2013 07:40 AM
rf 60x2 schematics? marko Car Audio 10 17th January 2010 09:54 AM
FS: Talema 1000VA 60x2 Xfmr + 2 x15000uF100V Caps sphinx Swap Meet 2 8th December 2008 01:34 PM
Selling a punch 250a2, old punch 75, and ppi epx 205 on EBAY ppia600 Swap Meet 0 23rd February 2008 01:17 AM
My experience: the cheap punch set VS Greenlee punch vax9000 Tubes / Valves 5 21st July 2006 07:52 PM


New To Site? Need Help?

All times are GMT. The time now is 09:29 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2