Amp repair question - MTX 1501D - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th March 2011, 03:11 AM   #1
diyAudio Member
 
Join Date: Mar 2011
Default Amp repair question - MTX 1501D

I have an MTX 1501D amplifier that does not work. The amp has been used very little, and worked fine for me while I had it. I sold the amp to a friend, and he may have damaged it trying to install it and gave it back.

I opened the case and did not find any discolored or burnt components. Are there problems that usually occur with these amps, or any ideas on what to check? I am good with electronics but I do not have an oscilloscope. Any diagrams, guides, or advice would be very much appreciated.
  Reply With Quote
Old 12th March 2011, 03:58 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Is the older model or the newer model (with the LED display on it)?
  Reply With Quote
Old 12th March 2011, 05:14 PM   #3
diyAudio Member
 
Join Date: Mar 2011
There is a small LED on the top of the amplifier. I believe this LED turns on but no sound comes out of the subwoofers when everything is connected.

Click the image to open in full size.
Click the image to open in full size.
  Reply With Quote
Old 13th March 2011, 05:17 AM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Is LED238 lighting up inside the amp?
  Reply With Quote
Old 4th April 2011, 05:20 PM   #5
diyAudio Member
 
Join Date: Mar 2011
I do not believe LED238 lights up, but LEDs 399 (highlighted by green box) and the large 463 that shows from the outside near the MTX logo both light up when the 12V and REM terminals are supplied with 12 volts. There is also a faint high-pitched tone that the amplifier emits as soon as it is connected to power, followed by a low volume hissing and crackling sound that continues until power is disconnected. I have attached some pictures of the amplifier. Any help or advice would be great. Thank you.

Click the image to open in full size.
Click the image to open in full size.
Click the image to open in full size.
Click the image to open in full size.

Last edited by Skew; 4th April 2011 at 05:50 PM.
  Reply With Quote
Old 4th April 2011, 07:31 PM   #6
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Quote:
I do not believe LED238 lights up
That's not definitive. Check it again. It may take several seconds for it to light up.
  Reply With Quote
Old 11th May 2011, 04:55 AM   #7
Gunman is offline Gunman  Russian Federation
diyAudio Member
 
Join Date: May 2011
Hello, dear friends! I'm from Russia, sorry foe my english
I have a problem with me 1501, do You have a circuit diagram (basic electric scheme, circuit scheme or electrical scheme)? Or may be You can take pictures of the elements (parts) inside it so close, so I can see numbers and letters on all elements?
  Reply With Quote
Old 11th May 2011, 06:05 AM   #8
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Which parts do you need to see?
  Reply With Quote
Old 11th May 2011, 06:22 AM   #9
Gunman is offline Gunman  Russian Federation
diyAudio Member
 
Join Date: May 2011
Quote:
Originally Posted by Perry Babin View Post
Which parts do you need to see?
all You can give to me
a half of an amp has burned
Can You help me?
  Reply With Quote
Old 11th May 2011, 06:48 AM   #10
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Post photos of the burned areas/parts.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MTX Thunder 1501D spooney Car Audio 49 16th July 2010 04:55 AM
Mtx 1501d catfishermike Car Audio 10 19th May 2010 05:56 PM
mtx 1501d ONEGGT Car Audio 0 18th October 2007 08:07 AM


New To Site? Need Help?

All times are GMT. The time now is 03:22 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2