Power Acoustik power supply - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th January 2011, 06:48 PM   #1
Dr Zeus is offline Dr Zeus  United States
diyAudio Member
 
Dr Zeus's Avatar
 
Join Date: Oct 2010
Default Power Acoustik power supply

Ive got two power acoustic amps of the same make and model with the same blown parts in the same place of the power supply. I didnt know things like this could even come in such exact pairs. Whats funny is the power supply fets actually have different numbers between them; 12 x 50N06 in one amp and 12 x PBF6000 in the other.

I need to replace all 12+12 fets. Can I order the same/better part for both? Looks like Digikey has them at the exact same rating. I'm swaying twards getting the 50N06's because I've eye'd those in other amps I've worked on plus can get them for a good price.

In the amp I'm working on today - it wont power up but the fets could also be to blame. I clipped off the ones which blew out and left 1/3 of them still attached because they were not registering shorted. Next to the TL494 is Q1 which is shorted from legs 1-3. The transistor is a 649A which I found a possible datasheet for.

649A pdf, 649A description, 649A datasheets, 649A view ::: ALLDATASHEET :::

Is there a part I can use in substitution to this 649A? I have an array of new parts and used parts for testing.

Click the image to open in full size.

Click the image to open in full size.
  Reply With Quote
Old 12th January 2011, 06:51 PM   #2
Dr Zeus is offline Dr Zeus  United States
diyAudio Member
 
Dr Zeus's Avatar
 
Join Date: Oct 2010
Also in the above photo you can see the red wire may be on the wrong side of the 1n4001 diode. This wire leads to what I beleive is a transformer which activates the amp's "Plasma effect" on the front cover. its kind of like one of those voltage globes at Spencers / Radio shack where the arc will follow your finger but in this case its a flat plastic piece. On the left you can see where it was possibly clipped, and on the right someone used heat-shrink and cold solder.
  Reply With Quote
Old 12th January 2011, 06:55 PM   #3
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
2N6491 installed facing the opposite direction due to the reversed pin configuration.

Most of the amps I've seen from Power Acoustik used the IRFZ44N. They're ~0.35 each from arrow. The 50N06 should also be OK.
  Reply With Quote
Old 12th January 2011, 07:02 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
You're right. See attached.
Attached Images
File Type: jpg PC130017b.jpg (180.4 KB, 120 views)
  Reply With Quote
Old 13th January 2011, 12:29 PM   #5
Dr Zeus is offline Dr Zeus  United States
diyAudio Member
 
Dr Zeus's Avatar
 
Join Date: Oct 2010
Thanks. I got this amp working with ~3 power supply fets. Now I just gotta wait for my parts. I have on order IRFZ44 and 50N06 transistors from Arrow.

Price beside, Which out of the three would be best fit and most reliable in any amplifier?

IRFZ44, 50N06, or PBF6000? Also, what about IRFZ48? Which can provide more power than any of the others? This amp uses 16 TIP35C/36C outputs and perhaps 12x power supply fets could not live up to the task.

Last edited by Dr Zeus; 13th January 2011 at 12:44 PM.
  Reply With Quote
Old 13th January 2011, 12:51 PM   #6
Dr Zeus is offline Dr Zeus  United States
diyAudio Member
 
Dr Zeus's Avatar
 
Join Date: Oct 2010
EDIT: Actually, dont mind my last questions so much. I just looked at a Hifonics Zeus VIII which has only 12 IRFZ44 power fets and 20+ TIP35/36 outputs.

Maybe the original installer was trying to wire some speakers wierdly with these two matching Power Acoustik amps. I could see where someone would buy these cheapy amps just to bridge them up and run both on a single DVC woofer at twice the rating of "2000" chinese watts. People do strange things.

Last edited by Dr Zeus; 13th January 2011 at 12:57 PM.
  Reply With Quote
Old 20th January 2011, 02:21 AM   #7
Dr Zeus is offline Dr Zeus  United States
diyAudio Member
 
Dr Zeus's Avatar
 
Join Date: Oct 2010
In re-building this amp's power supply, I ordered a large bundel of 100ohm 1/4w reisstors for the power fet gates... or so I thought. What I got from Mouser look a lot like 1/8w resistors. Also, should this amp really be using 100ohm gate resistors? The amp is a Power Acoustik Plasma Sphere 1920watt amp. I have two of these amps which power supplies blew their guts, and now would be the time to make it more reliable if I could.

I ordered this:
CFS1/4CT52R101G KOA Speer Carbon Film Resistors - Through Hole

And here they are on the left side. For comparison I placed some 1/4w Radio Shack brand resistors and a dime in the picture.
Click the image to open in full size.

Last edited by Dr Zeus; 20th January 2011 at 02:23 AM.
  Reply With Quote
Old 20th January 2011, 02:24 AM   #8
Dr Zeus is offline Dr Zeus  United States
diyAudio Member
 
Dr Zeus's Avatar
 
Join Date: Oct 2010
Power Acoustik Plasma Sphere 1920watt amp
  Reply With Quote
Old 20th January 2011, 02:35 AM   #9
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
To some degree, the wattage rating is determined by the materials that make up the resistor. It's possible to have 1/8 watt sized resistors rated for 1/4w. Of course, it's also possible that someone made a mistake.

1/8w resistors will not fail under normal operating conditions.

The original resistors were 100 ohms.

100w gate resistors are generally OK with IRFZ44s. If you're using something else, let us know.
  Reply With Quote
Old 20th January 2011, 03:00 AM   #10
Dr Zeus is offline Dr Zeus  United States
diyAudio Member
 
Dr Zeus's Avatar
 
Join Date: Oct 2010
I was going to use 50n06 transistors.

As for the 1/4 vs 1/8w resistors, I kept looking at Mouser, and indeed the sizes match up. These probably are 1/4w resistors just in a 1/8w package. i wonder if because they are 2% rather than 5% if that makes much of a difference in this case.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Acoustik TS980 sparks, blows fuses even without power on. BoeroBoy Car Audio 7 30th September 2010 02:17 PM
Power acoustik schematic brandes.cm Car Audio 11 21st January 2010 11:15 AM
Power Acoustik Amp Help 22chet Car Audio 7 22nd February 2009 10:05 AM
Power Acoustik Amp chadrock Car Audio 28 19th March 2008 05:37 AM
Help me to fix POWER ACOUSTIK please! Mordor Car Audio 10 13th February 2006 07:58 AM


New To Site? Need Help?

All times are GMT. The time now is 01:48 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2