Directed 650 5 channel amp - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th January 2011, 05:40 AM   #1
diyAudio Member
 
Join Date: Sep 2006
Default Directed 650 5 channel amp

I got this amp in for repair. The problem im having is the Output thats outlined has 22 volts on the first leg and 22 volts on the second leg and 0 volts on the 3rd leg . The driver thats circled has 26 volts on all 3 legs And the resistor that connects to the driver gets so hot it desolders itself from the board.

Any ideas on where to begin looking?

Last edited by mike49504; 10th January 2011 at 05:48 AM.
  Reply With Quote
Old 10th January 2011, 07:47 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Photo?
  Reply With Quote
Old 10th January 2011, 02:09 PM   #3
diyAudio Member
 
Join Date: Sep 2006
sorry thoght i put one in there
Attached Images
File Type: jpg hifonics 009.JPG (761.0 KB, 85 views)
  Reply With Quote
Old 10th January 2011, 02:27 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Can you post a photo of the bottom of the board covering the same section of the board?
  Reply With Quote
Old 10th January 2011, 02:50 PM   #5
diyAudio Member
 
Join Date: Sep 2006
Heres a pic of that section of board. I removed the output (tip 36) and the arrow points to the driver of that output
Attached Images
File Type: jpg hifonics 010.JPG (573.5 KB, 78 views)
  Reply With Quote
Old 10th January 2011, 03:12 PM   #6
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I'd suspect that Q209 or Q211 is leaking or shorted.
  Reply With Quote
Old 10th January 2011, 03:19 PM   #7
diyAudio Member
 
Join Date: Sep 2006
Replaced Q209 same thing . I dont see a Q11
  Reply With Quote
Old 10th January 2011, 03:35 PM   #8
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Q211.
  Reply With Quote
Old 10th January 2011, 03:43 PM   #9
diyAudio Member
 
Join Date: Sep 2006
sorry meant Q211 i dont see it
  Reply With Quote
Old 10th January 2011, 04:01 PM   #10
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
It may not be reading it correctly. It's next to Q207.

Left to right, what are each of the output transistors (TIP35/36)?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dx Troyan, a 650 watts channel amplifier. destroyer X Solid State 330 22nd April 2014 03:05 PM
Directed 650 mike49504 Car Audio 6 15th September 2010 06:04 PM
Sub channel not working - Directed 1100d5 CanadianDream Car Audio 8 12th December 2008 05:27 PM
B&K 650 tubecharts Mr. Triatic Tubes / Valves 4 11th May 2008 05:10 PM
Directed 500 Amp for sale squosh69 Swap Meet 0 29th January 2003 09:14 PM


New To Site? Need Help?

All times are GMT. The time now is 07:55 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2