Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th January 2011, 12:12 PM   #81
diyAudio Member
 
Join Date: Sep 2006
Should i try replacing the caps?
  Reply With Quote
Old 5th January 2011, 12:22 PM   #82
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If you're 100% sure that the noise is coming from the caps and you can find replacement caps, try it.
  Reply With Quote
Old 7th October 2012, 12:10 PM   #83
Viktor is offline Viktor  Yugoslavia
diyAudio Member
 
Join Date: Aug 2004
Location: Belgrade
Send a message via ICQ to Viktor
Default Zennon 7KW

Hi,

I can't find the service manual for the zennon oc cactus amplifier. I received for a repair one fully blown device which was once repaired and then blown again. I cleaned everything and replaced all transistors and driver IC's on amp driver board along with all resistors in gates and everything that measured wrong. Amplifier powers up and the sound is ok but after more than 50 W of output power it pops on speaker a few times and then shuts down. Since there is no distortion and the idle currents are low , there is no heating I suspect only the resistor values. I replaced the blown resistors with value that was on the old resistors but they were replaced in some other occasion. I need values for gate resistors for power supply output transistors mine are 1K which I found too big but maybe it is a part of the design. Other thing is that feedback resistor in the power supply controller is changed so I need also a value for R158 near 494 IC
Any help with these is very appreciated.

Viktor
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to 60hz to 50hz 7KW or more reliable but cheap!?? JinMTVT Everything Else 13 12th August 2009 03:23 AM
Lance Armstrong and Team Radio Shack pro cycling team Andersonix Everything Else 18 29th July 2009 04:39 PM
my graft cactus have succeeded! digi01 The Lounge 6 31st January 2005 03:32 PM


New To Site? Need Help?

All times are GMT. The time now is 06:50 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2