Linear Power 952 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th December 2010, 06:19 PM   #1
diyAudio Member
 
Join Date: Jun 2002
Location: non
Default Linear Power 952

Anyone have the schematic to this amp?

Someone has been in here prior to me and mucked around with it. theres some replaced transistors in the power supply area that arnt even in the right holes, probably not even the right transistors.

One of those transistors reads shorted.

All the outputs and power supply outputs read fine. Plus the bridge rectifier is clobbered up, like its missing, and 2 TO-247s just tacked in place of where the bridge used to be.

Like i said, its all mucked up. Any help would be appreciated.
  Reply With Quote
Old 16th December 2010, 06:31 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If no one can help, post a photo of the inside of the amp and I'll see if I have anything that may help.
  Reply With Quote
Old 16th December 2010, 06:40 PM   #3
diyAudio Member
 
Join Date: Jun 2002
Location: non
no camera.

no schematics?

Basically i need a list of all the small signal transistors in the power supply circuit, where they go, and what pins go where.

Last edited by mbates14; 16th December 2010 at 06:42 PM.
  Reply With Quote
Old 16th December 2010, 06:42 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I don't have anything on that specific amp.
  Reply With Quote
Old 16th December 2010, 08:28 PM   #5
diyAudio Member
 
Join Date: Jun 2002
Location: non
i got it running. one channel is totally fine but the other one is distorted.

the base of both drivers and both outputs on the bad channel is roughly between 8 to 10v DC bouncing around. scope shows the signal, but noisey and shifted above 0v.

caps test fine in that circuit.

Other channel perfectly fine.
  Reply With Quote
Old 16th December 2010, 10:19 PM   #6
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Email me. I have the audio schematic for the 2002. Maybe it's close enough to be of some help.

babin_perry@yahoo.com
  Reply With Quote
Old 17th December 2010, 02:05 AM   #7
diyAudio Member
 
Join Date: Jun 2002
Location: non
I figured it out. the Tip35 had opened. its funny though. never seen one open. just short.

replaced both the 35 and the 36, and it works just fine.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power One 5v 3A linear power supply SilverStrings Swap Meet 0 23rd September 2010 06:06 AM
Power One 12V 10A linear power supply boywonder Swap Meet 0 11th September 2010 03:38 PM
Linear Power 952 clayton Car Audio 48 20th May 2009 03:01 AM
Power One Linear Power Supply agent.5 Power Supplies 1 29th May 2006 06:06 PM
Linear power... Htguy Power Supplies 3 4th June 2005 08:15 AM


New To Site? Need Help?

All times are GMT. The time now is 04:57 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2