Alpine MRV-F300 Blowing fuses - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th November 2010, 04:13 PM   #1
diyAudio Member
 
Join Date: Nov 2010
Default Alpine MRV-F300 Blowing fuses

I have an alpine MRV-F300 that blows fuses just about as soon as it powers up. I opened it up and took out the board but didn't see anything that looked out of the ordinary. Any ideas what it could be or where I should start looking?

Thanks for the help!
  Reply With Quote
Old 12th November 2010, 04:29 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The most common fault that causes the amp to blow a fuse after the remote voltage is applied is shorted output transistors.
  Reply With Quote
Old 15th November 2010, 03:22 PM   #3
diyAudio Member
 
Join Date: Nov 2010
You are good Perry! I appears to be a D718 transistor. I am having a bit of trouble finding one though. Any ideas where to find one? Whether it's from a piece of equipment that I could pull it from or a substitute part I could use.

Thank you for the help!
  Reply With Quote
Old 15th November 2010, 05:03 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I've been using the FJA4213 and FJA4313 to replace the 2SB688 and 2SD718. Mouser has them. I don't remember using them in any Alpine amps but I've never had a problem using them as subs in other amps.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alpine MRP-F300 amp is dead, need help with repair gexamb Car Audio 37 24th October 2010 04:52 AM
Alpine mrv-f300 remote ciruit jol50 Car Audio 5 17th May 2010 07:33 AM
Alpine MRV-F401 or MRV-F400 Service Manual M.André Car Audio 6 21st February 2010 10:37 PM
Transistor replacement for Alpine F300 spooney Car Audio 7 14th January 2007 01:10 AM


New To Site? Need Help?

All times are GMT. The time now is 03:08 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2