Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Help with Power Acoustik PA-300
Help with Power Acoustik PA-300
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th November 2010, 10:16 PM   #11
Mote is offline Mote  Estonia
diyAudio Member
 
Join Date: Jul 2010
Location: Estonia
Replaced the ICs and the amp works perfectly.
Perry Babin and ppia600 - many thanks for input.
  Reply With Quote

Reply


Help with Power Acoustik PA-300Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Acoustik TS980 sparks, blows fuses even without power on. BoeroBoy Car Audio 7 30th September 2010 03:17 PM
Power acoustik schematic brandes.cm Car Audio 11 21st January 2010 12:15 PM
Power Acoustik A2400db spooney Car Audio 21 19th March 2008 01:05 AM
Elektor PA 300 amplifier supernet Elektor 10 13th February 2008 06:13 PM
Help me to fix POWER ACOUSTIK please! Mordor Car Audio 10 13th February 2006 08:58 AM


New To Site? Need Help?

All times are GMT. The time now is 10:54 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki