Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th October 2010, 02:42 PM   #1
diyAudio Member
 
Join Date: Sep 2006
Default Xtant 1001 D

I recieved this amp in for repair.

I believe the orginal power supply fets were the Z44's . The IRFZ48's are whats in it now. Will theese still work with the 10 ohm gate resistors?

Also Q3 thru Q10 and Q11 thru Q17 were also Z44's (orginals) and have been replaced with Z48's .

And last Q25 was IRL54 which now has a IRF540A in the amp.

Wondering if the Z48's will work in this amp since someone tryed repairing it before and within 15 mins in got stuck in protection mode and i have shorted transistors all thru the board now.
  Reply With Quote
Old 12th October 2010, 03:33 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The IRL version of the IRF540 is a logic level FET. The standard IRF540 may not switch on/off efficiently and may run hot.

The Z48s will probably be OK.

Are the outputs shorted?

If so, what are they?
  Reply With Quote
Old 12th October 2010, 03:52 PM   #3
diyAudio Member
 
Join Date: Sep 2006
2 of the outputs were shorted. The orginals were the Z44's atleast thats what MTX told me. The outputs that are in the amp now are the Z48's
  Reply With Quote
Old 12th October 2010, 04:07 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I don't have any experience with this particular model. Similar amps are very sensitive to substitute outputs. I don't know if this one is. The Z48s should be OK in the supply.
  Reply With Quote
Old 26th October 2010, 01:22 AM   #5
diyAudio Member
 
Join Date: Sep 2006
Back to this amp ,

I replaced the 8 outputs back to irfz44's and the gate resistors are new.

I havent messed with the bias or dc offset pots.

Upon powering it up the blue light will come on for a few secs the shut off and amp will start drawing excessive current.

Any ideas on what to check?
  Reply With Quote
Old 26th October 2010, 02:33 AM   #6
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Have you tried removing the rectifiers to isolate the output from the power supply to see if the excessive current draw was eliminated?
  Reply With Quote
Old 26th October 2010, 03:52 AM   #7
diyAudio Member
 
Join Date: Sep 2006
Pulled all rectifiers from the amp. When i power up the amp the blue light will come on for a sec then the red light comes on and stays lit and amp idles perfectly
  Reply With Quote
Old 26th October 2010, 03:59 AM   #8
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Is this the amp you have:
Xtant 1001dx inside - Amp Guts
  Reply With Quote
Old 26th October 2010, 04:01 AM   #9
diyAudio Member
 
Join Date: Sep 2006
Yes
  Reply With Quote
Old 26th October 2010, 04:15 AM   #10
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I've never repaired one of these. What are the ICs on the riser board?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
BEL 1001 repair info KevinC Solid State 7 25th February 2014 01:40 AM
Sony Playstation SCPH-1001 for parts. Destroyer OS. Swap Meet 0 28th April 2010 01:43 AM
Does anybody have the TS for Blueprint 1001 driver? toxic tuan Subwoofers 3 9th April 2006 10:30 PM
Blueprint 1001 TS parameters? toxic tuan Multi-Way 0 8th April 2006 08:30 AM


New To Site? Need Help?

All times are GMT. The time now is 06:52 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2