Looking for Soundstream Ref 644s Schematics - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th October 2010, 11:30 PM   #1
diyAudio Member
 
Zero Cool's Avatar
 
Join Date: Sep 2004
Location: MN
Default Looking for Soundstream Ref 644s Schematics

Looking for Soundstream Ref 644s Schematics. In fact looking for ANY soundstream schematics.

USA100 and SA80


Yes I HAVE contacted Soundstream they are of ZERO help and refuse to give out any service information what so ever.
  Reply With Quote
Old 8th October 2010, 02:13 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
What's wrong with the amp?
  Reply With Quote
Old 8th October 2010, 03:47 AM   #3
diyAudio Member
 
Zero Cool's Avatar
 
Join Date: Sep 2004
Location: MN
Nothing at the moment. Just picked it up off craiglist for $50. and wanted to find some schematics in case it dies. I replaced the RCA jacks that were broken, tore it apart and scraped all the dried up heatsink compound out of it, replaced a broken LED, re applied compound and cleaned it all up and and it runs great. MUCH more efficient then the alpine I have. with 2 channels running i got 81 watts at the onset of visable clipping with 30amps of current draw from the power supply. the alpine only did 51 wattsx2 channels for 30amps!

I need to find one of the screws for the remote turn on terminal or make one.
  Reply With Quote
Old 8th October 2010, 03:50 AM   #4
diyAudio Member
 
Zero Cool's Avatar
 
Join Date: Sep 2004
Location: MN
I also have a dead SA80 and USA100 amps that I need schematics to get running again. I fixed the power supply for the SA80 but there are 2 resistors i need to correct values for. they connect from the line that goes from the SG3524 chip to the mosfets and ground to drain the gate charge.
  Reply With Quote
Old 8th October 2010, 04:24 AM   #5
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Was the alpine clipping at 51 watts?

The smaller screws are #10-32 x 5/8". I use standard set screws as replacements when the originals aren't available.

On some of the amps that use the 3524 (SA244, SA245), the pulldown resistors are 75 ohms.
  Reply With Quote
Old 8th October 2010, 11:04 AM   #6
diyAudio Member
 
Zero Cool's Avatar
 
Join Date: Sep 2004
Location: MN
Yup alpine MRP-F200 which is rated at a ** 75x4 max and then in later years rated at 40x4 rms. I got 51 watts with 2 channels running (don't have 4 load banks on the bench) at visible clipping with 30amps of current draw.

There used to be a guy on eBay selling soundstream parts. I see he doesn't have anything listed lately. I found a screw that fits that I will cut off and make a set screw with.

75ohms eh? I started with 10 ohms but it would run. the original resistor was burnt up but it what i thought was a brown band still visible. I swapped them to 100ohms and the amp runs now but the IC gets warm. might be a normal warm but i wasn't sure.

Thanks for the 411
  Reply With Quote
Old 8th October 2010, 11:11 AM   #7
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Order the set screws from McMaster.com or get them from a local hardware store. Replace all of the original screws.

To protect the terminal blocks, use a lubricant like Synco's Super Lube on the set screws.
  Reply With Quote
Old 8th October 2010, 06:12 PM   #8
diyAudio Member
 
Join Date: Dec 2005
Location: Northern California
JandR still answers his emails, but does not openly sell on that auction site. Sterwart Electronics is open for business here near Sacramento. he is taking in repairs of the old gear and doing class A mods as well. He designed most of this gear. PM me if you need contact info, I will need your contact info to give you theirs....
  Reply With Quote
Old 9th May 2011, 11:39 PM   #9
MOER is offline MOER  United States
diyAudio Member
 
Join Date: Aug 2003
Location: SIMI VALLEY CA
Default Soundstream 644S schematics

Does anyone have the schematic for the Soundstream 644S

Please if you do email to me at zedaudio@aol.com


Thanks


Steve Mantz
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Soundstream Ref 414s repair pics dhamia Car Audio 13 14th October 2010 08:30 AM
soundstream 414 ref repair dhamia Parts 0 14th July 2010 11:02 PM
Soundstream Ref.405 railvoltage at sub-ch. gisewhcs Car Audio 4 24th June 2010 07:43 AM
soundstream ref 604 schematics lexneedssound Car Audio 30 19th February 2010 05:11 PM
Soundstream ref 414s Problem mrFrog Car Audio 16 11th June 2007 06:45 PM


New To Site? Need Help?

All times are GMT. The time now is 08:28 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2