Rockford Fosgate - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th October 2010, 09:24 PM   #1
dtisme is offline dtisme  United States
diyAudio Member
 
Join Date: Jul 2010
Default Rockford Fosgate

Got an older Fosgate amp. I believe its the 800 a2 (I attached a pic). The amp was working just fine without any problems then when I replaced my car battery, the amp no longer works. It did not smoke and does not smell burned. The fuse under the hood near the batter is still good and volt meter shows power all the way to the amp. At the moment the amp no longer powers on. It does not make a sound what so ever. They guys at Fys stated they think its a capacitor thats blown on the insdide. You guys helped with my Hifonics amp so I thought to check here to see if anyone knows what it could be. If it is a capacitor issue does anyone know what kind to get from (Mouser, Digikey, etc)? Anything else it could be please let me know. Thanks
  Reply With Quote
Old 5th October 2010, 11:39 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
You need to confirm that you have sufficient power supply voltage. With your multimeter set to DC volts, the black meter probe on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red probe alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts on either the B+ or remote line, you need to check the wiring feeding whichever line is too low. If 'both' the B+ and remote turn-on lines are low and your battery is fully charged, you may have a bad ground connection.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rockford Fosgate BD1500.1 mike49504 Car Audio 4 17th March 2011 10:39 PM
Rockford Fosgate BD500 mike49504 Car Audio 9 18th July 2010 07:43 AM
Need help with Rockford Fosgate 801s robsmetalcraft Solid State 3 27th February 2010 09:28 PM
Rockford Fosgate 801s mike49504 Car Audio 11 17th February 2010 11:47 PM
rockford fosgate transistors mike49504 Car Audio 2 20th January 2007 03:26 AM


New To Site? Need Help?

All times are GMT. The time now is 09:33 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2