Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

ppi pcx 1250 problem
ppi pcx 1250 problem
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 20th August 2010, 02:18 PM   #1
3nCod3R is offline 3nCod3R  United States
diyAudio Member
 
Join Date: Aug 2010
Location: New York
Default ppi pcx 1250 problem

The amp stays in standby all the time drawing almost an amp. Any ideas ?
  Reply With Quote
Old 20th August 2010, 05:33 PM   #2
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Have you checked the output transistors?
  Reply With Quote
Old 20th August 2010, 05:54 PM   #3
3nCod3R is offline 3nCod3R  United States
diyAudio Member
 
Join Date: Aug 2010
Location: New York
I have not checked anything on the board yet, just a visual inspection that has revealed a hot resistor (R34) which feeds one of the transistors. It reads 80 ohms, the others in the same bank read 18 ohms. The next question is how to remove the board from the case, it seems they must have a jig to assemble/disassemble this unit. All the transistors are clipped in to a rail on both sides of the board.
  Reply With Quote
Old 20th August 2010, 06:19 PM   #4
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Read THIS.

You can probably check the outputs without removing the clamps.

What transistor (part number on face of transistor) is that resistor connected to?
  Reply With Quote
Old 20th August 2010, 06:35 PM   #5
3nCod3R is offline 3nCod3R  United States
diyAudio Member
 
Join Date: Aug 2010
Location: New York
Got the clamp off, works well when you know the trick, thanks. The part number on the transistor is RFP70N06, and it is cracked wide open.
  Reply With Quote
Old 20th August 2010, 07:13 PM   #6
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
You'll need to replace all of the RFP70N06s. You still need to check the output transistors.
  Reply With Quote
Old 18th October 2010, 05:22 PM   #7
3nCod3R is offline 3nCod3R  United States
diyAudio Member
 
Join Date: Aug 2010
Location: New York
Default update on pcx 1250 current draw when off

Just an update for anyone who has this type of problem in the future.....replaced all of the mosfets for the power supply and the unit functions normally. There were several that were shorted, and since they are in parallel, it was causing voltage to drop on the gate resistors. Thanks for the help !
  Reply With Quote

Reply


ppi pcx 1250 problemHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
repairing PPI PCX-2200 redblaze Car Audio 20 27th December 2013 12:19 AM
PPI PCX-2200 took it toll on subs skooter Car Audio 7 26th November 2007 03:32 AM
PPI PCX-2200 connectors needed skooter Car Audio 2 25th November 2007 03:31 AM
PPI PCX-2200 manual needed skooter Car Audio 4 24th November 2007 01:27 PM
burnt resistors on PPI PCX-1250 cutlass1991 Car Audio 9 19th September 2006 11:38 PM


New To Site? Need Help?

All times are GMT. The time now is 05:50 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki