Power Acoustic, unhappy mosfets - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 22nd July 2010, 01:49 PM   #1
diyAudio Member
 
Join Date: Dec 2007
Default Power Acoustic, unhappy mosfets

Hi there;

I'm having trouble with a Power Acoustic A4200db

I've replaced all the fets in the power supply,
and their gate resistors.

I used RPF70N06's in place of the IRFZ46n's that were in there.

All the output fets are new as well.

It powers up fine, but draws too much current idling.

I see that the fets on one phase are happy, but the ones on the other phase of the power supply are getting pretty hot.

With a scope, and all the fets out of the circuit, the waveforms on the PMW chip are uniform, but when I insert
the new fets back in, one phase gets skewed


You can see by this picture, the top wave has quite a bump on it, that's the problem phase.


I was thinking maybe a shorted torroid, but this is a split PS with 2 transformers why would just that phase get go squirly on both ?

Got any ideas ?
Attached Images
File Type: jpg MVC-012F.JPG (33.5 KB, 65 views)
  Reply With Quote
Old 22nd July 2010, 02:03 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Driver transistors?
  Reply With Quote
Old 22nd July 2010, 03:15 PM   #3
diyAudio Member
 
Join Date: Dec 2007
Sorry, I forgot to mention the totem pole drivers test good with a meter, not leaky or shorted, I have not replaced them yet, and that's why.
  Reply With Quote
Old 22nd July 2010, 03:24 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If the driver transistors are not defective, all of the gate and pulldown resistors are within tolerance and there are no open traces, the driver IC may well be defective.

Does the gate drive signal for any power supply FET (taken from the gate leg of the FET) look different than the gate drive signal on any other power supply FET?
  Reply With Quote
Old 22nd July 2010, 04:03 PM   #5
diyAudio Member
 
Join Date: Dec 2007
Yes, the gate from one of the fets that is heating up still has a slight bump on the top, near the leading edge.

Taken from a fet that is cool, there is no bump and the transistion is a slight bit smoother
  Reply With Quote
Old 22nd July 2010, 05:15 PM   #6
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
You may have a defective FET if the gate resistors are within tolerance and it's only visible on one of the FETs.
  Reply With Quote
Old 23rd July 2010, 09:03 AM   #7
diyAudio Member
 
Join Date: Dec 2007
Quote:
Originally Posted by Perry Babin View Post
You may have a defective FET if the gate resistors are within tolerance and it's only visible on one of the FETs.
yeah, the gates on all the fet's on that phase of the PS look the same.

Maybe you're right about that driver ic, I'll try changing it and see what happens.
Thanks Perry
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unhappy Ice amp eAR Acoustic Reality service problems Al.M Class D 2 20th December 2009 02:18 PM
power acoustic 620-2 scampo77 Car Audio 4 23rd June 2009 01:35 AM
unhappy marriage (oscillations) jitter Solid State 13 8th January 2009 05:47 PM
Unhappy with the Lilliput design Cassiel Tubes / Valves 18 5th September 2005 08:37 AM
unhappy with aleph3 cowanrg Pass Labs 14 2nd October 2004 02:16 AM


New To Site? Need Help?

All times are GMT. The time now is 08:16 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2