HIFONICS bxi 1606d - Page 2 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th July 2010, 10:18 PM   #11
timwebb is offline timwebb  United States
diyAudio Member
 
Join Date: Jan 2010
Location: memphis tn
ok ive cleaned the amp off and the 494 is getting no power? on the bottom of the amp it has heat damage should i replace it?
  Reply With Quote
Old 13th July 2010, 11:05 PM   #12
timwebb is offline timwebb  United States
diyAudio Member
 
Join Date: Jan 2010
Location: memphis tn
Quote:
Originally Posted by timwebb View Post
ok ive cleaned the amp off and the 494 is getting no power? on the bottom of the amp it has heat damage should i replace it?
ok now its getting 12v and 4.95v on the third pin
  Reply With Quote
Old 14th July 2010, 03:44 AM   #13
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
With the power supply FETs out of the circuit, do you read ~5v DC on the gate pad for every power supply FET?
  Reply With Quote
Old 14th July 2010, 04:02 AM   #14
timwebb is offline timwebb  United States
diyAudio Member
 
Join Date: Jan 2010
Location: memphis tn
the protect light comes on now but goes back off.and im not reading anything

Last edited by timwebb; 14th July 2010 at 04:12 AM.
  Reply With Quote
Old 14th July 2010, 04:48 AM   #15
timwebb is offline timwebb  United States
diyAudio Member
 
Join Date: Jan 2010
Location: memphis tn
Quote:
Originally Posted by timwebb View Post
the protect light comes on now but goes back off.and im not reading anything
ok i get 4v on the gate pads
  Reply With Quote
Old 14th July 2010, 06:00 AM   #16
timwebb is offline timwebb  United States
diyAudio Member
 
Join Date: Jan 2010
Location: memphis tn
the 494 is putting out a good signal and i get a good signal on the gate pad
  Reply With Quote
Old 14th July 2010, 12:41 PM   #17
m4ick is offline m4ick  United States
diyAudio Member
 
Join Date: Jan 2010
Location: Gainesville, FL
Wow, that amp is completely different from the bxi1606d I just fixed.
  Reply With Quote
Old 14th July 2010, 02:12 PM   #18
timwebb is offline timwebb  United States
diyAudio Member
 
Join Date: Jan 2010
Location: memphis tn
the layout is different than what im use to dealing with brutus amps.

the 494 just started making a frying noise and them made a little smoke.what should i check before replacing this chip?

Last edited by timwebb; 14th July 2010 at 02:30 PM.
  Reply With Quote
Old 14th July 2010, 06:14 PM   #19
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
4v on the gate pads should indicate that you have a good drive signal, especially if all gate pads had the same voltage.

What was replaced before you applied power?

Did you have the transistors tightly clamped to the heatsink?

Which transistors smoked?
  Reply With Quote
Old 14th July 2010, 06:34 PM   #20
timwebb is offline timwebb  United States
diyAudio Member
 
Join Date: Jan 2010
Location: memphis tn
i changed four diodes cause they were leaking and checked the 494 and it was hot then i saw smoke come from it.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hifonics Brutus BXI 2008D mike49504 Car Audio 13 17th February 2012 04:21 AM
Hifonics Brutus BXi 1606d parts Bertje Car Audio 2 3rd June 2010 03:33 PM
Hifonics 1606D & 1608D mosfets? Doffo Class D 1 24th October 2009 05:17 PM
Hifonics Bxi 1606d Please Help dmeche Class D 3 25th July 2009 07:15 PM
hifonics BXi 1606D burnt resistors??? gadgeteer123 Class D 7 30th June 2009 08:55 PM


New To Site? Need Help?

All times are GMT. The time now is 09:48 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2