Memphis 16-PR1KD - Page 2 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th July 2010, 04:02 AM   #11
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Check all of the transistors you replaced to see if there are any solder bridges. Clean the flux from the board with acetone.
  Reply With Quote
Old 6th July 2010, 06:43 AM   #12
timwebb is offline timwebb  United States
diyAudio Member
 
Join Date: Jan 2010
Location: memphis tn
ok i cleaned and checked for solder bridges it powers up fine but the dc offset light comes on what should i be looking for?
  Reply With Quote
Old 6th July 2010, 09:09 PM   #13
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Post a list of the circuit board designations for ALL of the driver components that you replaced.
  Reply With Quote
Old 6th July 2010, 10:13 PM   #14
timwebb is offline timwebb  United States
diyAudio Member
 
Join Date: Jan 2010
Location: memphis tn
i fixed it found some shorted output drivers and it cut off i wanted to replace the power supply transistors. it plays but its an old amp.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Memphis 16-ST500D mike49504 Car Audio 21 3rd August 2014 11:30 PM
Memphis 16-st1000d Componentr Car Audio 13 8th October 2012 02:01 AM
Memphis 16-PR1KD amp repair help (pix) raverx3m Car Audio 15 24th April 2012 08:07 AM
problem with my amp memphis 16-pr1kd pollo1008 Class D 0 29th December 2009 10:20 PM
memphis 16-pr1kd chev55_steve Car Audio 0 2nd January 2009 10:46 AM


New To Site? Need Help?

All times are GMT. The time now is 12:12 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2