diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Car Audio (http://www.diyaudio.com/forums/car-audio/)
-   -   Soundstream Rubicon 302 (http://www.diyaudio.com/forums/car-audio/167540-soundstream-rubicon-302-a.html)

mike49504 27th May 2010 03:06 AM

Soundstream Rubicon 302
 
Im working on this amp it had power supply and output problems. I replaced the NDP6060's in it with NDP7060's I also replaced the outputs in the amp and emitter resistors.

Amps power light will not light up but its producing rail voltage I have bot + -30volts on the outputs.

This is the voltages i get from the SG3524N DO theese appear to be right or do i have a problem still

1:0
2:2.54
3:0.18
4:0
5:0
6:3.46
7:2.17
8:0
9:4.32
10:0
11:6.92
12:18.86
13:18.85
14:6.93
15:18.85
16:5.08

Power supply Fets
1:6.50
2:13.89
3:0

Perry Babin 27th May 2010 03:39 AM

It looks OK. If you move the power supply rail switch to the other position, does the LED light up?

mike49504 27th May 2010 03:52 AM

No cant get it to light at all

Perry Babin 27th May 2010 03:54 AM

Is that the only problem (does the amp produce clean audio)?

mike49504 27th May 2010 03:58 AM

Amp has DC voltage on left channel and right channel is dead

Perry Babin 27th May 2010 04:06 AM

Do you have clean audio an the point where R30/32 connect together?

Do you have clean audio an the point where R33/34 connect together?

You shouldn't have more than a few millivolts of DC on either of these.

mike49504 27th May 2010 04:13 AM

Where r30-32 meet no signal

R33 and 34 meet no signal

0 volts across the emitters

Perry Babin 27th May 2010 04:44 AM

Try moving the airbass switch to the other position and check for signal again. You may need to work it and the other switches back and forth to clean their contacts.

mike49504 27th May 2010 04:56 AM

tryed moving the switch about 100 times back and fourth along with the others still no signal.

Perry Babin 27th May 2010 07:27 AM

Drive a strong audio signal into the amp and post the op-amp outputs that have signal. You only need to check the output pins of the op-amps.


All times are GMT. The time now is 10:34 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2