help please with PPI d/1000 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th April 2010, 10:31 PM   #1
diyAudio Member
 
Join Date: Apr 2010
Default help please with PPI d/1000

First I would like to say high everyone , an from the looks of thing's you guys really know your stuff. I have a brand new ppi d/1000 running a set of boston acoustics g5's 12in. It gets cold out here an for some reason my amp sweats to the point of it getting soaking wet even when its not on. The other day I turned on my radio an my amp went into protection mode an will not come back on. I removed the amp from my car an dryed it off an took a hair dryer an dryed it off but it still will not come on. Is this something I can fix an if not does anyone know of a good ppi repair shop. thanx in advance
  Reply With Quote
Old 4th April 2010, 11:20 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Does it go into protect or does it do nothing?

Have you confirmed that you have a good ground and that you have sufficient voltage on the B+ and remote terminals?
  Reply With Quote
Old 5th April 2010, 05:12 PM   #3
diyAudio Member
 
Join Date: Apr 2010
yes the ground an the positive terminals as well as the remote are fine
  Reply With Quote
Old 5th April 2010, 06:14 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Did you measure the DC voltage with a multimeter?

Does it go into protect or does it do nothing?
  Reply With Quote
Old 6th April 2010, 03:49 AM   #5
ppia600 is offline ppia600  United States
diyAudio Member
 
Join Date: Jun 2007
Location: Louis y ana
You may have a water leak in your car creating a lot of humidity that is condensing on that amp because of its warmth. Make sure to check that out as well, if you repair it you want it to stay repaired.
__________________
Don't worry... you can always turn the gain down!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PPI amp mike49504 Car Audio 12 20th December 2009 10:49 PM
old ppi connectors damage Car Audio 7 17th January 2009 12:45 PM
PPI ART Series a404 "v" PPI Powerclass pc450 swap chemhaz Car Audio 2 21st November 2008 02:23 PM
Need help tuning PPI skooter Car Audio 5 21st January 2008 06:02 PM
PPI vs. Alpine smokeaway Solid State 2 28th August 2005 10:51 AM


New To Site? Need Help?

All times are GMT. The time now is 10:59 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2