Ppi a600 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 17th March 2010, 05:27 AM   #1
diyAudio Member
 
Join Date: Sep 2006
Default Ppi a600

The power supplyu in this amp is blown. The fets in it are SMP25N06.

Is there a good replacement (sub) for theese?

Also what ohm resistors are they using for the gates. Since evryone in this amp is toast
  Reply With Quote
Old 17th March 2010, 06:19 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The gate resistors are 100 ohms, most likely. I'd try the IRFZ44. The IRFZ34 is generally a drop-in replacement for the 25N06s but The Z44 should be OK. If you use the Z44s, monitor the temperature of the power supply FETs for about a minute after replacing them. If they remain cool, you shouldn't have to make any other changes.
  Reply With Quote
Old 20th March 2010, 10:47 PM   #3
diyAudio Member
 
Join Date: Sep 2006
The NDP7060's wouldnt work would they?
  Reply With Quote
Old 21st March 2010, 01:44 AM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If I'm not mistaken, the driver IC drives the FETs directly. I don't know if it can reliably drive 8 7060s. Long term reliably could be a problem.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PPI A600 improvement manina Car Audio 7 3rd April 2009 03:16 AM
PPI A600 problems Riveted1 Car Audio 5 29th January 2009 08:35 PM
Ppi A600 npenson Car Audio 4 27th August 2008 10:36 PM
Upgrading a PPI A600.2 MazdaBoi Car Audio 6 12th March 2008 07:47 PM
PPI A600.2 Troubleshooting Help digitalloving Car Audio 4 17th August 2007 07:26 AM


New To Site? Need Help?

All times are GMT. The time now is 09:15 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2