Kicker zx150.2 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 22nd February 2010, 11:26 PM   #1
diyAudio Member
 
Join Date: Sep 2006
Default Kicker zx150.2

I got 2 of theese amps in for repair i believe they have the same problem.

Amp has no output.

I checked for rail voltage at outputs i have nothing .

I checked power supply fets with amp powered up black prob on chasis ground

Leg1:0
Leg2:13.92
Leg3:0

The reading are from the power supply fets IRF44's

wondering what to check at this point?
  Reply With Quote
Old 22nd February 2010, 11:30 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
A photo of the inside of the amp would be helpful.

The voltage on the 494?

IC#
Pin 1:
Pin 2:
Pin 3:
Pin 4:
Pin 5:
Pin 6:
Pin 7:
Pin 8:
Pin 9:
Pin 10:
Pin 11:
Pin 12:
Pin 13:
Pin 14:
Pin 15:
Pin 16:
  Reply With Quote
Old 23rd February 2010, 12:06 AM   #3
diyAudio Member
 
Join Date: Sep 2006
Ok i repaired a few solder joints on the rectifiers and now on the outputs i have 27.89 On the middle leg of tip 35

On tip 36 i only have 2.24 on the middle leg


tl494
1:1.08
2:3.64
3:.06
4:0
5:1.51
6:3.42
7:0
8:12.32
9:5.16
10:5.16
11:12.32
12:13.89
13:5.03
14:5.03
15:5.03
16:4.32
Attached Images
File Type: jpg kicker1.JPG (155.8 KB, 49 views)
File Type: jpg kicker2.JPG (155.4 KB, 44 views)
File Type: jpg kicker3.JPG (127.6 KB, 41 views)
  Reply With Quote
Old 23rd February 2010, 12:21 AM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Assuming that you used the secondary center tap as the reference, the lack of voltage could be caused by...

open rectifier
broken connection on rectifier
broken connection on jumper wire connecting the rectifier to the outputs
  Reply With Quote
Old 23rd February 2010, 01:43 AM   #5
diyAudio Member
 
Join Date: Sep 2006
Ok i repair the issue with the rectifiers i now have both postive and negative rail voltages on outputs.

Still no output from either amp.

wondering where i go from here?
  Reply With Quote
Old 23rd February 2010, 01:48 AM   #6
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Is the preamp board connector labeled to show the left and right signal pins?

If so, see if there is audio at that point.

Have you run all pots and switches through their entire range?
  Reply With Quote
Old 23rd February 2010, 02:15 AM   #7
diyAudio Member
 
Join Date: Sep 2006
On the connecter pins its labled R -15 SGND +15 L

Pin1:.01
pin2:-14.57
pin3:.04
pin4:14.65
pin5:.09

If that helps any
  Reply With Quote
Old 23rd February 2010, 02:24 AM   #8
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
You'd have to drive the input with a strong signal and measure the AC voltage on the L and R pins.
  Reply With Quote
Old 23rd February 2010, 02:36 AM   #9
diyAudio Member
 
Join Date: Sep 2006
i drove the inputs with 8 volts and measured the left and right pins

left pin:14.79 volts

right pin:14.33 volts

meter set on ac
  Reply With Quote
Old 23rd February 2010, 02:43 AM   #10
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Follow the traces from the L and R pins (on the main board). What is the first transistor it goes to? It likely goes through a resistor before going to the transistor.

Is one leg of that transistor connected to the secondary center-tap?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kicker zx750.1 texasrebel1 Car Audio 2 10th January 2009 04:46 PM
I need help with a Kicker DX700 chipper Class D 5 8th January 2009 07:45 PM
kicker warhorse tadej Car Audio 10 17th August 2008 03:05 AM
Kicker Amps skooter Car Audio 3 8th November 2007 03:53 AM


New To Site? Need Help?

All times are GMT. The time now is 08:54 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2