dynaBel 5kW amp fault - blown transistors + - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 15th February 2010, 04:53 PM   #1
codegen is offline codegen  Norway
diyAudio Member
 
Join Date: Dec 2006
Send a message via MSN to codegen
Default dynaBel 5kW amp fault - blown transistors +

I have a big amplifier who has some blown transistors in it. Output`s seems okey, but havent measured them yet, will do tomorrow.

The real problem is that i have no schematics over the amp, and it is some blown resistors witch i cannot read the colorcodes of, but maybe someone knows anyhow? Look at the attached pictures.

There is also a blown KIA494 PWM Controller there, TL494 would be a good replacement?

There are also some diodes there witch i believe to be wasted, called FMU32U, i cannot find information about the exact FMU32U, but i found some about FMU32. Im looking for a replacement for those to, would MUR3060 do the trick?
Attached Images
File Type: jpg SANY0988.JPG (762.2 KB, 108 views)
File Type: jpg SANY0989.JPG (802.6 KB, 87 views)
File Type: jpg SANY0990.JPG (787.3 KB, 70 views)
File Type: jpg SANY0991.JPG (816.7 KB, 74 views)
File Type: jpg SANY0992.JPG (761.7 KB, 74 views)
File Type: jpg SANY0993.JPG (793.2 KB, 44 views)
File Type: jpg SANY0994.JPG (725.7 KB, 39 views)
File Type: jpg SANY0995.JPG (777.8 KB, 36 views)
  Reply With Quote
Old 22nd February 2010, 04:20 AM   #2
jol50 is offline jol50  United States
diyAudio Member
 
Join Date: Nov 2007
I would clean the resistors off with something, maybe acetone and see if they look better. Pretty sure the 494 are the same.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help needed Output Transistors blown Rossy Parts 21 14th February 2007 03:14 PM
Blown output transistors crest amp mechaboy1 Solid State 28 9th January 2007 11:17 PM
my new 4.5kW class-d amp (crown BCA topology) mzzj Class D 28 19th December 2005 11:37 AM


New To Site? Need Help?

All times are GMT. The time now is 05:33 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2