Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Alpine MRD-M300 TDA7571
Alpine MRD-M300 TDA7571
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th January 2010, 12:46 AM   #1
brandes.cm is offline brandes.cm  United States
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Default Alpine MRD-M300 TDA7571

Well my mrd-m300 repair went crazy tonight. I waited a week for the replacement irf5305 fets only to have them fry and take out the TDA7571 chip or vice versa.

I had this amp working with IRF9540 in place of the 5305's for a temperory test. Replaced with original parts and the output would start off looking good then get all distorted. I didn't have the screws holding the pcboard in place when it partially worked. Those screws tie the pcboard to the heatsink. Put the screw in, then everything went up in a pop!!

Should I look for the IC, prelim searches show no stock anywhere.

Any thoughts???
  Reply With Quote
Old 27th January 2010, 01:03 AM   #2
brandes.cm is offline brandes.cm  United States
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
The partstore.com has it $30, ouch!! Don't know if I will pay that much to fix this amp.
  Reply With Quote

Reply


Alpine MRD-M300 TDA7571Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Alpine mrd-m1005 schematics for repair Mr.Monkeys Car Audio 5 25th September 2017 06:51 AM
Blown Alpine MRD-M605 amp paulieb81 Car Audio 20 18th January 2010 08:51 PM
Alpine mrd-m501 Repair dj_square- Car Audio 2 31st August 2009 05:15 AM
Alpine MRD-605 no output cobology Class D 0 21st February 2009 12:45 AM
Upgrade Alpine mrd-605? hc_TK Car Audio 1 5th April 2006 03:21 PM


New To Site? Need Help?

All times are GMT. The time now is 12:15 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki