Hifonics zeus gen x - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 26th December 2009, 04:57 AM   #1
diyAudio Member
 
Join Date: Sep 2006
Default Hifonics zeus gen x

Wondering if anyone has pics of the power supply section of this amp?

I recieved this amp in bad condition there is caps missing, and the gate resistors have been cobbled.

The board says 75 ohm resistors but i think they put a differnt value in them during production

There are 1/8 watt and a 1/4 resistor tied together in the amp right now and the value is 240 ohms so wondering if anyone knows what value the gate reisitors need to be
  Reply With Quote
Old 26th December 2009, 09:30 AM   #2
diyAudio Member
 
Join Date: Sep 2006
They are using buz102's for the power supply fets wondering if you might know what gate resistors i should put in this amp cause like i said someone tied 2 resistors together and came up with 240 ohms total for the gate resistors
  Reply With Quote
Old 26th December 2009, 09:37 AM   #3
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
What's more important is what sub you're going to use. If the FETs have not failed, a 100 ohm would probably work but the 75 ohm would definitely be a good, safe value.
  Reply With Quote
Old 26th December 2009, 09:55 AM   #4
diyAudio Member
 
Join Date: Sep 2006
Not sure what subs hes going to use all the fets are good in the amp so if i put 75 ohm resistors in the amp he should be good on any sub he decides to run?
  Reply With Quote
Old 26th December 2009, 10:08 AM   #5
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The gate resistors have nothing to do with the speaker load. If they're too high in value, they FETs will likely fail even without a speaker load. The 75 ohm resistors should be a safe value.

When you get the amp up and running, make sure the idle current isn't excessive. If it doesn't seem excessive, turn the DC voltage on the power supply down to ~11v. If the idle current increases when you reduce the DC voltage, there is a problem. If the idle current remains the same or decreases when you lower the DC voltage, everything is likely OK.
  Reply With Quote
Old 26th December 2009, 07:19 PM   #6
diyAudio Member
 
Join Date: Sep 2006
Hi Perry,

I opened up a Hifonics gen x thor amp and they are running the same fets as the zeus but the gate resistors that they used in that amp(thor) are 47 ohm

Says the same on the board 75 ohm but right from the factory they had 47 ohm gate resistors in it.

Wondering if i can put the 47 ohm gate resistors in the zeus amp and be fine
  Reply With Quote
Old 26th December 2009, 09:38 PM   #7
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I can't think of any reason that the 47 ohm resistors wouldn't work.
  Reply With Quote
Old 26th December 2009, 11:43 PM   #8
diyAudio Member
 
Join Date: Sep 2006
Ok I talked to one of the designers on this amp and he said the 47 ohm gate resistors wont work it will turn the amp on the supply to fast and wont shut down fast enough or something like that. And he said ill get whats called a crossfire in the supply.

He said he couldnt remember what they used but it ws either a 220 ohm or a 240 ohm resistor for the gates

Wondering what would be better the 220 or 240 ohm?
  Reply With Quote
Old 27th December 2009, 12:15 AM   #9
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
There's virtually no way for the 220 ohm resistors to work. You stated that you opened an amp that used the same FETs and used 47 ohm resistors so it's obvious they will work.

I think he meant cross-conduction which is more likely to occur with a gate resistor with too much resistance.

In some amps, there are resistors connected to the gate resistors that can have values between 100 and 220 ohms. These are pull-down resistors.

What FETs are being used in this amp?
  Reply With Quote
Old 27th December 2009, 12:32 AM   #10
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Is this a ZED designed amp?

If so, they did use 220 ohm resistors at least up to the series 7 amps but they set the dead-time higher than normal so that there would be no cross conduction.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
hifonics zeus vii mike49504 Car Audio 6 30th April 2012 05:31 PM
hifonics zeus viii transformer... marko Car Audio 33 3rd January 2011 07:43 PM
hifonics zeus xi mike49504 Car Audio 68 12th February 2009 05:23 PM
Need help identifying an early hifonics Zeus jeclute Car Audio 4 5th June 2007 07:05 PM
Hifonics Zeus VII redimp Car Audio 1 20th December 2006 10:47 PM


New To Site? Need Help?

All times are GMT. The time now is 09:38 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2