Memphis Belle st-1300d - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th October 2009, 04:44 AM   #1
SS64 is offline SS64  United States
diyAudio Member
 
Join Date: Mar 2008
Default Memphis Belle st-1300d

OK picked this amp today for $80 at a swap meet.. the Amp physically is like a 9/10... Ok here is the problem.. It does not turn on.. Power supply checks out ok. No big burns on the board.. The only thing that was wrong is C741 next to the tl494 daughter board exploded.. there is almost nothing left of it... I think that it is a 10uf 50V because the one next to is the same value.
Can anyone tell me where to go from here? Should I just replace the cap and try it?
__________________
It isn't fun unless it can kill you!
  Reply With Quote
Old 12th October 2009, 05:56 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Post the DC voltage on all 16 pins of the TL494. Place the black meter probe on chassis ground. Place the red meter probe on the point where you need to measure the voltage.

494
Pin 1:
Pin 2:
Pin 3:
Pin 4:
Pin 5:
Pin 6:
Pin 7:
Pin 8:
Pin 9:
Pin 10:
Pin 11:
Pin 12:
Pin 13:
Pin 14:
Pin 15:
Pin 16:
  Reply With Quote
Old 12th October 2009, 02:24 PM   #3
SS64 is offline SS64  United States
diyAudio Member
 
Join Date: Mar 2008
OK I pulled it out of the sink last night to check the underside of the board for burnt traces.. everything looks good.. I'll get the pin voltages today perry..
__________________
It isn't fun unless it can kill you!
  Reply With Quote
Old 12th October 2009, 07:49 PM   #4
SS64 is offline SS64  United States
diyAudio Member
 
Join Date: Mar 2008
Ok here are the voltages
pin1- 0.019
pin2- 0.082
pin3- 5.06
pin4- 0.041
pin5- 1.515
pin6- 3.774
pin7- 0.020
pin8- 12.64
pin9- 4.96
pin10- 4.96
pin11- 12.67
pin12- 12.67
pin13- 5.06
pin14- 5.07
pin15- 5.06
pin16- 0.020

all measurements taken in vdc.
__________________
It isn't fun unless it can kill you!
  Reply With Quote
Old 12th October 2009, 08:48 PM   #5
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Do you have the voltage on pins 2 and 3 reversed?

Do you have positive and negative voltage on the rectifiers?

Do you have positive and negative 15v on the op-amps?

Do you get audio from any of the channels?

In the future, copy and paste the column of numbers I post. It will save time and if you have negative values, the colons are less confusing than the dashes.
  Reply With Quote
Old 13th October 2009, 12:10 AM   #6
SS64 is offline SS64  United States
diyAudio Member
 
Join Date: Mar 2008
Well It works I think the shorted c741 was keeping it from coming on..Idles at 2.583 amps..
Thank you for your help perry..
__________________
It isn't fun unless it can kill you!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
knock off Belle Klipsch? capt mike Multi-Way 12 6th December 2009 08:00 PM
Belle Canto opera recordings jp_howard Music 0 18th April 2009 03:13 PM
FS/memphis belle mb-17 6-channel 1200 watt at 2-ohm beast ncamps Swap Meet 0 14th April 2009 02:01 PM
Memphis Belle ST-1300D valterdaw Car Audio 1 3rd October 2007 06:01 PM


New To Site? Need Help?

All times are GMT. The time now is 10:10 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2