Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 1st May 2003, 02:37 AM   #1
diyAudio Member
 
Join Date: Feb 2002
Location: Charleston, SC
Default What do you think?

So I just blew up the pair of JL 8W3's I had in my Jetta. I'm running them off an Xtant 121M. I have a pair of Image Dynamics IDQ10's or three JL 8W6's that I could use as new subs. I'm leaning toward the JL's because I personally think they sound a little 'tighter'. What do you guys think? THey'd be in a small sealed enclosure suspended under the rear deck.
  Reply With Quote
Old 1st May 2003, 03:13 AM   #2
diyAudio Member
 
JOE DIRT®'s Avatar
 
Join Date: Apr 2003
Location: Brantford, ON
I would stick with the JL`s and turn down the damn gain on the amp...LOL
  Reply With Quote
Old 1st May 2003, 01:05 PM   #3
diyAudio Member
 
Magnetmaz's Avatar
 
Join Date: Nov 2002
Location: Pittsburgh, PA
Send a message via AIM to Magnetmaz
I personally have seen more problems with JL audio subs than any other, so i steer clear of them. Sure, they are nice at first...they sound good..the logo is cool

But they wear much faster than any sub i've ever seen...blow out...have issues with the cone seperating.

-Maz
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



New To Site? Need Help?

All times are GMT. The time now is 12:47 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2