jl audio 300/4 repair - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th June 2009, 07:27 PM   #1
diyAudio Member
 
Join Date: Jun 2009
Default jl audio 300/4 repair

Hey guys I have a jl audio 300/4 that has messed up. It wont play out one speaker chanel, and it fried the speaker that was hooked into that chanel. Can any one point me in the right direction to find some info on repairing this. Thanks

Brian
  Reply With Quote
Old 13th June 2009, 07:01 PM   #2
diyAudio Member
 
Fuzzymuff's Avatar
 
Join Date: Mar 2009
Default Elaborate please

Whats all messed up? You burnt anything? Is the wire a mess, pcb?
Why is a channel gone? Have you checked Output Transistors?

Have you searched?



Banging my head against some mad bvgger's wall!

Fuzzymuff
__________________
Wrap it in foil, and plug it in.
  Reply With Quote
Old 15th June 2009, 11:53 PM   #3
jol50 is offline jol50  United States
diyAudio Member
 
Join Date: Nov 2007
With no speakers or input and amp on, see if you have DC voltage on that channel and see what others are. They should be near 0v.
  Reply With Quote
Old 16th June 2009, 06:45 AM   #4
Dimon74 is offline Dimon74  United States
diyAudio Member
 
Join Date: Feb 2008
This is a common problem with this amp.One or two IRF540 on channel which has DC voltage shorted.Also check gate resistors.If it not going to help.Look on LED lights on driver boards.If the channel working properly all lights will be on.If it not, check two zeners diodes on bottom of the driver board.They have SOT-23 case and marked 6,8 Y
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cambridge Audio A5 repair job pulseezar Solid State 36 6th May 2012 03:06 PM
Help to repair JL audio 300/2 Solosound Car Audio 42 20th March 2009 01:52 AM
lightning audio amp repair doughboi916 Car Audio 14 31st August 2007 10:05 PM
Atlas Audio Repair Helen Parts 2 31st August 2007 04:41 AM


New To Site? Need Help?

All times are GMT. The time now is 08:09 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2