Why doesnt Rockford amps have a fuse???? - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th May 2009, 06:23 PM   #1
diyAudio Member
 
Join Date: Apr 2009
Question Why doesnt Rockford amps have a fuse????

what is says, Why doesnt Rockford amps have a fuse?

every other amp I have or seen all have one or more fuses built in, just seems weird that Rockford amps dont.
__________________
Jensen KA 4660HLx 4ch 540W
Pyramid PB675 4 ch 800W
  Reply With Quote
Old 12th May 2009, 10:56 PM   #2
Eva is offline Eva  Spain
diyAudio Member
 
Eva's Avatar
 
Join Date: Oct 2003
Location: Near the sea
Send a message via MSN to Eva
They want to reduce amplifier manufacturing cost and increase repair cost when they fail.
__________________
I use to feel like the small child in The Emperor's New Clothes tale
  Reply With Quote
Old 12th May 2009, 11:15 PM   #3
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Since ~2004, most all Rockford amps have had on-board fuses.
  Reply With Quote
Old 13th May 2009, 09:35 AM   #4
winny is offline winny  Sweden
diyAudio Member
 
Join Date: Sep 2007
Quote:
Originally posted by Eva
They want to reduce amplifier manufacturing cost and increase repair cost when they fail.
That, and CE-marking/China-friendly-EU-legislation allowed them to do so. At least here that's the case for just about all new products.
  Reply With Quote
Old 14th May 2009, 04:05 AM   #5
jol50 is offline jol50  United States
diyAudio Member
 
Join Date: Nov 2007
Oh come on you guys, when I got into this in the late 80s very few had them. I recall Alpines did, a pyramid I had did, but nothing else I can remember had fuses in the amp case itself....though I imagine some others did. Many amps then had 8ga wires sticking out and that was it. Had to put a fuse holder on each one, those strange glass tube fuses, lol. With a nice deluxe amp, a new fuse holder came with it.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuse housing melting but fuse not blowing, ppi amp rawadia Car Audio 21 2nd August 2008 11:39 AM
New Rockford Fosgate Amps Efficiency paintrodsey Car Audio 2 6th May 2007 11:38 PM
Amps pilot light doesnt turn in, speaker doesnt work silentblackhat Solid State 2 17th March 2006 04:08 PM


New To Site? Need Help?

All times are GMT. The time now is 06:27 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2