help me with my amplifier - Page 2 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th April 2009, 04:35 PM   #11
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
You can check to see if they're shorted in the circuit. That's the most common failure mode.
  Reply With Quote
Old 28th April 2009, 05:21 AM   #12
pong is offline pong  Philippines
diyAudio Member
 
Join Date: Jan 2009
checked the IRF640's today.. its A ok.

o btw i just remembered my DC Power supply only runs at 1.23mA(i checked it last night with my dvom) i was just wondering could it be the PSU cant turn on the circuit thats why it turns to protect mode???i'll try to borrow from my friend tonoght see what happens.

any other tests that i can do?..i was worried i'll fry the fets again.
  Reply With Quote
Old 28th April 2009, 09:36 AM   #13
luka is offline luka  Slovenia
diyAudio Member
 
luka's Avatar
 
Join Date: Sep 2005
Location: in Slovenia :)
Send a message via Skype™ to luka
why the hell did you buy SLA1500???? this is not a 1500w amp, more like 1200w if that, has pretty much bad sound, but is "pretty" cheap...fun first amp, until you have something else, which is a lot better

I have schema for it, if you want... It is from some model before, but at least you have latest model, I think it is still
__________________
home page @ http://www.classdaudio.tk/ @ 24/7 all year long
I FEEL SLOVENIA
  Reply With Quote
Old 28th April 2009, 11:25 AM   #14
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
pong:
You should get a proper power supply before you do any more troubleshooting. If the supply is rated for more than 5 amps, insert a 10 amp fuse in the B+ line before you power up the amp. Have all transistors clamped to the heatsink to prevent them from overheating if there is a problem causing the amp to draw excessive current.

The protection LED generally only illuminates when there is a problem in the audio section (and sometimes during the turn-on mute delay).

luka:
Does the schematic show the circuit for the audio driver board? I'm looking for the part number for the 14 pin IC.
  Reply With Quote
Old 28th April 2009, 11:28 AM   #15
pong is offline pong  Philippines
diyAudio Member
 
Join Date: Jan 2009
ohh... i think they have perfectly the same schema and layout..weird..this amp is a sound magus x1502..yeah pretty quite cheap amp.. but pushes very good though.

can i have a copy of your schema?this would be a great help!thanks luka.

my bad should have invested on a good ac-dc supply.
i'll be borrowing from a friend tonight..hope some good would turn out..

  Reply With Quote
Old 28th April 2009, 12:37 PM   #16
luka is offline luka  Slovenia
diyAudio Member
 
luka's Avatar
 
Join Date: Sep 2005
Location: in Slovenia :)
Send a message via Skype™ to luka
Quote:
Originally posted by Perry Babin
luka:
Does the schematic show the circuit for the audio driver board? I'm looking for the part number for the 14 pin IC. [/B]
No Perry, it does not [at least I think so, don't remember anymore], I would need to contact guy in charge for this amps here, that is what Company Sinus live said to me

Can't you read what that part is, like with UV or something like that?
__________________
home page @ http://www.classdaudio.tk/ @ 24/7 all year long
I FEEL SLOVENIA
  Reply With Quote
Old 28th April 2009, 12:45 PM   #17
luka is offline luka  Slovenia
diyAudio Member
 
luka's Avatar
 
Join Date: Sep 2005
Location: in Slovenia :)
Send a message via Skype™ to luka
Quote:
Originally posted by pong
ohh... i think they have perfectly the same schema and layout..weird..this amp is a sound magus x1502..yeah pretty quite cheap amp.. but pushes very good though.

can i have a copy of your schema?this would be a great help!thanks luka.

my bad should have invested on a good ac-dc supply.
i'll be borrowing from a friend tonight..hope some good would turn out..

Hmm diffrent name but same same same board LOL


1
2
3
4

Click the image to open in full size.
Versions of SLA, bottom looks just like yours

Click the image to open in full size.My amp, when I had it
__________________
home page @ http://www.classdaudio.tk/ @ 24/7 all year long
I FEEL SLOVENIA
  Reply With Quote
Old 28th April 2009, 02:00 PM   #18
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The top of the IC was ground too deeply on all of the ones I've seen.
  Reply With Quote
Old 28th April 2009, 02:30 PM   #19
djQUAN is offline djQUAN  Philippines
diyAudio Member
 
Join Date: May 2004
Location: manila
Send a message via MSN to djQUAN Send a message via Yahoo to djQUAN
Quote:
Originally posted by luka

Hmm diffrent name but same same same board LOL


1
2
3
4

Click the image to open in full size.
Versions of SLA, bottom looks just like yours

Click the image to open in full size.My amp, when I had it

that's because only one company made those. Sound Magus is the house brand the company used for their own amps. but they still make amps for others.
  Reply With Quote
Old 28th April 2009, 03:32 PM   #20
diyAudio Member
 
Join Date: Sep 2004
Hi LUKA,

Which glue arround the toroid transformer used ? Because this is very helpful to absorb to socks when the car running on bad roads

Thanx[IMG]Click the image to open in full size.[/IMG]
__________________
ssmir
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wanted: DIY amplifier builder with experience. I need a 0.7 ohm stable amplifier Audiophilenoob Swap Meet 34 17th May 2005 12:58 AM
Questions about how to decrease the PASS A-40 amplifier into a class AB amplifier. novtango Pass Labs 2 21st October 2002 02:50 AM


New To Site? Need Help?

All times are GMT. The time now is 01:13 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2