us acoustics usx1000 (zed) problems - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 26th March 2009, 12:20 AM   #1
diyAudio Member
 
Join Date: Mar 2009
Default us acoustics usx1000 (zed) problems

i have a small problem, or maybe a big one. my us acoustics started to smell as if it were fried, but it never shut off or lost power. infact it still worked great. but when i took it apart to see what was going on i found that one of the power supply fets was broke off the board!! and the one across from it on the board was dead. i had a bunch of irfz44 transistors laying around and thats what was in the amp so i replaced the two bad ones and put it back together. after cranking it up a few times i noticed the smell again. so i took it back out and checked the power supply transistors again. they were all ok!! so now i find that one of the big output transistors has one broken leg and the one across from it is loose in the board. i pulled both out and a few others and checked them all and they all are ok. so i put it all back together and made sure the board is secure in the heatsink. but i have not yet hooked it up. im just wondering what could be causing that smell. there is no sign of burned up parts and no burned traces. so could it have been the loose or broken output tranistors?, even though they arent bad?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fm acoustics ben goh Solid State 29 28th May 2012 05:49 PM
Q's about the acoustics of fans nunayafb Everything Else 0 29th March 2006 04:19 AM
Raw Acoustics HT3 audioferret Multi-Way 15 12th March 2006 12:48 AM
Need help in Acoustics! audioPT Multi-Way 13 1st December 2003 10:13 PM


New To Site? Need Help?

All times are GMT. The time now is 05:32 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2