1000D Memphis Amp ? - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 18th March 2009, 07:45 AM   #1
diyAudio Member
 
Join Date: Mar 2009
Send a message via MSN to Hoppy72450 Send a message via Yahoo to Hoppy72450
Question 1000D Memphis Amp ?

I have just recently got an amp free its suppose to be a 1,000 watt amp but when I hook it up the protection like comes on then goes off like it should but the Power light has been broken and the amp is not putting out anything. I took it apart and never seen any burnt parts is there something specific I should be looking for ?
  Reply With Quote
Old 18th March 2009, 09:01 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
When the red light goes off, can you hear the relay click?
  Reply With Quote
Old 26th March 2009, 09:09 AM   #3
slikck is offline slikck  United States
diyAudio Member
 
Join Date: Mar 2009
Hey there! im new to this forum. Glad i found this very interesting activity's in here. anyways not to thread jack but im having the same issues with the same amp 1000.1 memphis amp. when the power is connected in like a few seconds the relay CLICK's! then it goes onto Protection mode. Open it up nothing is burnt? What could be the problem? any helps would be appreciated!
  Reply With Quote
Old 26th March 2009, 02:21 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Are you sure it's the same amp. I can't find any Memphis amp that uses the model number of 1000.1 that's similar to the 16-ST/MC1000D.
  Reply With Quote
Old 26th March 2009, 08:11 PM   #5
slikck is offline slikck  United States
diyAudio Member
 
Join Date: Mar 2009
sorry about that. i just double checked it and its the "Memphis Power Reference 1000.1" i believe we are talking about the same one
  Reply With Quote
Old 26th March 2009, 08:48 PM   #6
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Can you send me a photo of the inside of the amp?

babin_perry@yahoo.com
  Reply With Quote
Old 27th March 2009, 05:14 AM   #7
slikck is offline slikck  United States
diyAudio Member
 
Join Date: Mar 2009
check your email Parry
  Reply With Quote
Old 23rd April 2011, 02:48 AM   #8
diyAudio Member
 
Join Date: Mar 2011
hey, I have a real mc1000d and I have that same issue, I replaced the 3205's and checked the resistors and still have no output. I wish I had access to a scope but I dont. Are there any problem areas on the mc and st1000d's I should look for?
  Reply With Quote
Old 23rd April 2011, 01:41 PM   #9
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Start a new thread and post the DC voltage on all pins of the TLx94 IC on the power supply driver board. Place the black meter probe on the amplifier's ground terminal. Place the red meter probe on the point where you need to measure the voltage. Copy and paste the following list into your reply.

Pin 1:
Pin 2:
Pin 3:
Pin 4:
Pin 5:
Pin 6:
Pin 7:
Pin 8:
Pin 9:
Pin 10:
Pin 11:
Pin 12:
Pin 13:
Pin 14:
Pin 15:
Pin 16:
  Reply With Quote
Old 23rd April 2011, 05:07 PM   #10
diyAudio Member
 
Join Date: Mar 2011
thanks perry, sorry for thread digging. I wish there were people like you in the automotive tuning field.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Memphis...? hooverjr10 Subwoofers 0 14th December 2007 04:16 AM
power supply issues memphise 1000d jf8620 Car Audio 1 10th May 2006 11:05 PM
Memphis 1000D Transistor Blowing jf8620 Car Audio 46 12th March 2006 11:49 PM
Kicker Vs. Memphis irokpierce Car Audio 1 23rd August 2005 04:12 PM
memphis car amp accept Car Audio 0 20th July 2003 06:36 PM


New To Site? Need Help?

All times are GMT. The time now is 06:58 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2