Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Precision Power PC6600.2 Amp turns on then immediately turns off. Need help!
Precision Power PC6600.2 Amp turns on then immediately turns off. Need help!
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th March 2009, 02:03 PM   #1
autolink is offline autolink  Guam
diyAudio Member
 
Join Date: Mar 2009
Default Precision Power PC6600.2 Amp turns on then immediately turns off. Need help!

Hi I got a used Precision Power PC6600.2 Amp that turns on then immediately turns off. I opened to check if there were any visible damages but I am unable to find any. Can anyone direct to what I should check first? Thanks in advance.
  Reply With Quote
Old 12th March 2009, 08:57 PM   #2
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Do not operate the amp without the cover in place.

Have you checked the output transistors to see if any are shorted?

The outputs are the ones with their 3rd legs connected to the large resistors. You should not read anything near 0 ohms between any of the legs of any individual transistor.
  Reply With Quote
Old 13th March 2009, 12:42 AM   #3
autolink is offline autolink  Guam
diyAudio Member
 
Join Date: Mar 2009
How do I test it? I can't seem to find it. Sorry.
  Reply With Quote
Old 13th March 2009, 01:20 AM   #4
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I should have asked this before...
Did you confirm that the amp had sufficient voltage at the B+ and remote terminals and a good ground?


If the power supply feeding the amp is OK, read through the basic repair page below. It will make troubleshooting the amp much easier.
  Reply With Quote
Old 15th March 2009, 02:12 AM   #5
autolink is offline autolink  Guam
diyAudio Member
 
Join Date: Mar 2009
Yes I currently have an amp installed, but it does not work when I use the PPI amp.
  Reply With Quote

Reply


Precision Power PC6600.2 Amp turns on then immediately turns off. Need help!Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
On-off LED turns off when I turn the Power on! gychang Class D 4 6th July 2009 12:49 PM
Help with an amp, turns on but no sound HeavyD'sCustom Car Audio 40 5th May 2009 03:36 PM
Old school Coustic Amp 160:turns on with no remote power spooney Car Audio 17 16th August 2008 05:33 AM
Which turns you on? nl Digital Source 0 30th July 2004 10:50 PM


New To Site? Need Help?

All times are GMT. The time now is 06:15 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki