crossover amp hookup - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 23rd February 2009, 09:29 PM   #1
diyAudio Member
 
Join Date: Feb 2009
Default crossover amp hookup

I have an orion amp I am trying to hookup to my component speakers. My problem is this I hook up all the wires and everything and when I connect the wires to the crossovers my midrange speakers work but my tweeters play nothing but static. am i wiring something wrong? with my old amp they worked perfectly fine going thru the tweeter. I am hooking up a hp 2400 orion amp to a set of orions c2 6.2 component speakers and polks DB6501 component speakers. Passive Crossovers
  Reply With Quote
Old 24th February 2009, 11:33 PM   #2
ppia600 is offline ppia600  United States
diyAudio Member
 
Join Date: Jun 2007
Location: Louis y ana
Default Re: crossover amp hookup

Sounds like the lowpass or bandpass switch is on. Check and make sure the switch on the amp is in full range or high pass/hp mode.
Also, are you sure the orion is a full range amp? It may only play low frequencies/designed for running sub woofers.
Could you post a pic of your amp or give the exact model number?


Quote:
Originally posted by jonesk1978
I have an orion amp I am trying to hookup to my component speakers. My problem is this I hook up all the wires and everything and when I connect the wires to the crossovers my midrange speakers work but my tweeters play nothing but static. am i wiring something wrong? with my old amp they worked perfectly fine going thru the tweeter. I am hooking up a hp 2400 orion amp to a set of orions c2 6.2 component speakers and polks DB6501 component speakers. Passive Crossovers
__________________
Don't worry... you can always turn the gain down!
  Reply With Quote
Old 26th February 2009, 11:40 AM   #3
diyAudio Member
 
Join Date: Feb 2009
Default hp 2400 orion

yea the amp is hp 2400 its right on there website. The people i bought from says that it is perfect for my component speakers. yea I had switched to full range and then tried high freq still nothing and i know it has to do with amp for simple fact i had my speakers hooked up to a different amp and they worked fine
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hookup wire Buzzy Solid State 6 4th July 2008 01:39 AM
behringer dcx HOOKUP IMSTOOPID Digital Line Level 8 5th February 2008 06:21 PM
Tranny hookup... john65b Power Supplies 11 5th January 2008 08:29 PM
sub hookup questions wharfrat Subwoofers 6 11th July 2004 09:12 PM


New To Site? Need Help?

All times are GMT. The time now is 05:46 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2