Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th December 2008, 08:11 PM   #1
diyAudio Member
 
Solosound's Avatar
 
Join Date: Jun 2008
Exclamation New sick amplifier

Again arrive to me this broken amplifier.

This is one 4040DSM by the punch.

The power source is blown.
Click the image to open in full size.

I find two different mosfets; are two IRFZ44 and two IRFZ46.
Click the image to open in full size.

¿What are the right part number?

¿Some one remember the right part for the drivers? I view two resoldered marked like “2A”
Click the image to open in full size.

The rectifiers diodes, one is resoldered (maybe changed) marked LM7915CT and the original is 7815CT.

The amplifier section, apear be fine.

I will buy some parts today from Newark. ¿should I buy any more to prevent time delay?
  Reply With Quote
Old 4th December 2008, 09:44 PM   #2
Eva is offline Eva  Spain
diyAudio Member
 
Eva's Avatar
 
Join Date: Oct 2003
Location: Near the sea
Send a message via MSN to Eva
7815 and 7915 are +15V and -15V regulator ICs respectively.

The mix of IRFZ44 and IRFZ46 in the power supply is probably due to a bad repair job and it's enough by itself to cause trouble.
__________________
I use to feel like the small child in The Emperor's New Clothes tale
  Reply With Quote
Old 4th December 2008, 09:49 PM   #3
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The 2A parts are MMBT3906s.

The original FETs were probably BUZ11s but either the Z44 or the Z46 would be a good sub.
  Reply With Quote
Old 5th December 2008, 01:29 AM   #4
ppia600 is offline ppia600  United States
diyAudio Member
 
Join Date: Jun 2007
Location: Louis y ana
Yeah, replace all four power supply fets with the same part number. Irfz44 seems to be a good all around replacement these days.
__________________
Don't worry... you can always turn the gain down!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sick Carver M-1.0t amp: bad caps? sblack6 Solid State 1 7th June 2009 07:53 AM
Got this on this on ebay..sick amp benny_rx_blanco Car Audio 2 8th April 2009 10:18 PM
Sick Peavey IPS800 amplifier Original Burnedfingers Solid State 1 24th April 2008 11:42 AM
My Linn Axis is Sick. Please help fix bubbamc119 Analogue Source 53 26th January 2008 12:08 AM
Help - Z4 sick on startup BeaufortRalph Pass Labs 5 18th April 2005 06:50 PM


New To Site? Need Help?

All times are GMT. The time now is 01:48 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2