xtant A2002 amp burnt? - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th November 2008, 09:08 PM   #1
hbch is offline hbch  United States
diyAudio Member
 
Join Date: Nov 2008
Default xtant A2002 amp burnt?

The sub woofer wires touched and shorted out causing my amp to fail.
I opened it up and found 4 parts that are burnt. I have no idea what they are.

I want to switch them out and see if I can get it to work again.

The 4 parts burnt are next to 8 other parts that look the same with different numbers. They are all pinched under an aluminum bar.

The number on the circuit board where the three prongs from each part connect is FET700, FET701, FET703, and FET704

The part number of the actual part is only slightly visable on one part. This is M75N06.... and CQ231 (not sure on the "1" on that last number)

Any Idea where to get these parts and what they are?
Thanks
  Reply With Quote
Old 12th November 2008, 10:52 PM   #2
Eva is offline Eva  Spain
diyAudio Member
 
Eva's Avatar
 
Join Date: Oct 2003
Location: Near the sea
Send a message via MSN to Eva
These are MTP75N06 from the power supply. In the Car-Audio section you may find many threads describing problems like yours and explanations on how to repair it. This is a common problem.
__________________
I use to feel like the small child in The Emperor's New Clothes tale
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! tube amp burnt? flatsound Tubes / Valves 9 26th June 2009 02:41 AM
xtant 604 x mike49504 Car Audio 8 29th November 2008 08:00 AM
xtant a2002 amp genes66 Car Audio 3 26th February 2008 07:48 PM
Need Help - Burnt Sanken p.heimpold Solid State 16 30th May 2007 05:05 PM


New To Site? Need Help?

All times are GMT. The time now is 11:28 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2