kenwood KDC-MP825 doesnt close properly - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 20th October 2008, 01:48 PM   #1
leko916 is offline leko916  United States
diyAudio Member
 
Join Date: Nov 2007
Send a message via AIM to leko916 Send a message via Yahoo to leko916
Default kenwood KDC-MP825 doesnt close properly

recently my Kenwood KDC-MP825 head stopped operating properly. It seems that sometimes when I turn off the car, the face inst closing properly. then, the next time i turn on the car, the face will slide out, fold down, turn on, but then it will slide back into the unit (still flipped down) and the unit turns off. when I press the power button it will repeat this sequence, usually leaving the face in a different tilted position each time it slides back in. sometimes I can turn it off/on many times and eventually it will start working again. this morning I couldn't get it working after 45 minutes of fiddling. I would guess that somethign is not sync'd inside and it doesn't recognize what position the face is in, but that's totally a guess. that's why Ia m asking here

if anyone has any ideas, please help. This forum was very helpful last time I had an issue with this head, almost exactly a year ago when the amp went out. I am thinking maybe its time to replace the unit but would like an opinion as to what may be wrong and how involved it will be to fix first. Thanks a ton!
  Reply With Quote
Old 23rd October 2008, 10:54 PM   #2
Spax is offline Spax  United Kingdom
diyAudio Member
 
Join Date: Oct 2008
A bit of a generalisation here but a weak point in any headunit that flips is the ribbon cable connecting the face to the head unit.

If you can get a close look at the cable look for signs of stress cracking or tearing, the cable may be damaged and only making an intermittent connection.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
looking for a sub amp - doesnt have to be a plate.... needmorstuff Swap Meet 1 12th August 2009 09:24 PM
Kenwood KDC-MP825 head Unit repair leko916 Car Audio 14 12th November 2007 03:06 AM
CD player Drawer open close open close open close qguy Digital Source 7 23rd November 2006 08:58 PM
Amps pilot light doesnt turn in, speaker doesnt work silentblackhat Solid State 2 17th March 2006 03:08 PM


New To Site? Need Help?

All times are GMT. The time now is 09:38 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2