Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th May 2008, 11:48 AM   #1
Bertje is offline Bertje  Netherlands
diyAudio Member
 
Join Date: Jan 2004
Location: Holland
Default Blade SE4.2 repair

I have a Blade SE4.2 defect, one channel has a lot of crossover distorsion (low bias???), other channel sometimes works OK sometime it fails without going into protection, (bad soldering contacts i suppose) .

I think these amps are (very) rare, someone overhere know some more of these amps ? Class H....?

Rob.
  Reply With Quote
Old 11th February 2009, 04:18 PM   #2
ThomasH is offline ThomasH  Germany
diyAudio Member
 
Join Date: Jan 2009
Send a message via ICQ to ThomasH
Hmm ...
is this the old amp from Sjord?
I´ve got a SE4.2 fromthe netherlands and it didn´t work ...
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KEF Concept Blade infinia Multi-Way 14 11th June 2009 04:42 PM
blade grenade amp rsc Car Audio 2 11th February 2009 04:16 PM
unipivot vs blade as bearing c3conv Analogue Source 8 29th September 2008 12:13 PM
Blade se4.2 Clipped Car Audio 2 9th October 2007 05:25 AM
MDF: What saw blade and screws to use? feke67 Multi-Way 12 6th January 2003 09:57 PM


New To Site? Need Help?

All times are GMT. The time now is 07:24 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2